My scene won't render

Hello, I am having a little trouble with this blend file (and the last one I tried to render). I have the camera set up in the right place, the location to which it’s supposed to render is there, the file type has been chosen and set up, but when I click on “render” or “animation”, it renders every frame as a blank image. I don’t know why this is happening, and any help will be appreciated!


Here is the file.

You have strips in the sequencer, and those don’t contain the scene strip so it won’t render the 3D scene at all.

Disable the sequencer in render properties -> post-processing.

OH! So if I just delete the strips, tender the animation as an AVI, and add in the audio layer, it’ll work correctly?

Absolutely not.

One does not simply render to a video file. Always render animations to image format, then compile the resulting image sequence into a video file, adding audio.

There are many more reasons to do so instead of rendering to a video file, but these few should be enough:

  • you can stop or crash the render without losing data and having to re-render everything
  • depending on the image format, you don’t lose rendered data. Png is lossless in visual range of values, .exr saves everything
  • encoding an image sequence is much faster than rendering a 3D scene. You don’t lose quality if you have to re-encode with different settings, or do additional compositing, when you have a lossless image sequence to start with

This takes unchecking one checkbox and you can render the 3D scene after that. It disables the sequencer so you don’t have to touch the strips there, until it’s time to work in the sequencer again.