my snapping suddenly stopped working?

At some point during my modelling session, all snap tools have stopped working. I usually make extensive use of the CTRL key for impromptu snapping. I noticed that stopped working and tried all the other snapping modes and they also don’t now work. Except the ‘increment’ mode just locks the vert to it’s original position.

I just can’t get the little orange circle around snapping targets to appear…

Quitting and restarting Blender hasn’t solved the issue.

Has anybody else experienced this?

I’m on WindowsXP 32bit 2.63.0 r46461

Ok, at some point I had toggled off ‘snap onto itself’, toggled it back on and my snapping works again. I always assumed the CTRL key snapping worked whether this was on or off? Obviously it needs to be on.

Sorry for the wasted new topic.

I was about to jump off my balcony until I found this thread. Thanks for taking the time to post it! :smiley:

Just wanted to add that if your view distance is set too high and you haven’t set your orbit to a point close to what you’re looking at (number pad period key) this can also cause the snapping to stop working.

Good question. I ran into the same problem. Thanks for posting.


Feel free to use: