My texture is blurry in the 3D viewport

I am trying to make a minecraft-like game and I am starting with creating Steve. And he is blurry… How can I make him not blurry ?

Blend file: http://www44.zippyshare.com/v/15112300/file.html

Anticipated thanks,
Marron.

deselect mipmaps in system in preferences