My UV mat is slipping.

In the UV editor window I have the mat all lined up and right, but when I go to render it looks like it’s sliding half off of where it’s supposed to be.

you have to set the texture to be mapped to the uv coordinates, in order to do that you have to klick the UV button in the map input panel of the material settings.
btw, when uploading .blend files you should “pack” the file beforehand, that saves all the images, textures … into the .blend so that the people who download the file have the textures aswell.
that can be done by klicking file>external data> pack into blend.

Oh crap! Thanks, I guess I’m a bit absent-minded today.