My viewport position gets locked

This should be an easy one, as I am very much a noob, but in trying to modify an .STL from Thingiverse to fit my application, and even after saving the imported .STL as a Blender model, the position of my viewport gets locked to where all I can do is pan. My research indicates that I may can select my object, a vertex, or even plop my cursor (the red and white hoop with the crosshair) somewhere and get focus back and be able to move, but so far I have remained “set in concrete” and not going anywhere. I have also been told about some settings in Preferences, which so far also hasn’t worked. How do I make sure I can continue to move my viewport around to continue editing? I am using Blender 3.01 in Windows 10, Windows 11, and Linux Mint (seperate machines.)

I can only guess that you got a blend file with custom navigation settings. Default “Middle mouse Action” in Keymapping of the preferences is Orbit.

Hold Shift when you move with the Middle Mouse Button to alter between panning and orbiting.

Maybe your viewport is locked to the camera in the scene and that camera might be locked in it’s rotation. “Camera to View” should be unchecked (located in the viewports right panel - press N to toggle it).

This is the 3D cursor and is the location at which blender usually spawns new objects, when you add one. It’s also used for some tools as a reference point or to snap things to it.

Also here is a great video about traps in viewport navigation, just for an easier entrance to blender :wink: