nasty tangent problem

I’ve been doing the Jonathan Williamson tutorial on modelling a light bulb on CG Cookie, just to get a bit more practice, and have encountered a fault in my material shaders.

This is what I was going for:
http://commons.wikimedia.org/wiki/File:Jw_cg_bulb.JPGhttp://upload.wikimedia.org/wikipedia/commons/7/7e/Jw_cg_bulb.JPG

Instead I got this:
http://upload.wikimedia.org/wikipedia/commons/3/3d/Bulbcap-help-withtangent.jpg

As you can see, the light distribution is messed up, and it looks like bent pewter, when i was going for a brushed steel appearance.
I fiddled around, and this is the same mesh with Tangent deselected:
http://upload.wikimedia.org/wikipedia/commons/a/aa/Bulbcap-help-notangent.jpg

These are my material buttons settings for the object:
http://upload.wikimedia.org/wikipedia/commons/5/59/Light-bulb-settings.JPG

I tried going through the tutorial again twice, with new materials and textures, and got the same result every time. The only conclusions i can come up with are that either it’s my own error, in which case please tell me what I’ve done wrong and how to fix it, or it’s a software error, in which case please tell me what Blender is doing wrong and how to fix it. If it helps, I’m using the 2.49a version. The object in question has a 2 level subsurf, and has been set smooth with normals recalculated outwards.

It’s not overly urgent - I’m not doing this for a project or anything - I’d just rather the same problem not crop up again when i AM doing work for a project. Help please
http://commons.wikimedia.org/wiki/File:Jw_cg_bulb.JPG

anyone fancy helping?

anybody? Please?

Tangent shading doesn’t work with Ray traced shadows… for some reason??!
Thats your problem :(, try using shadow buffer