Neck Filling help [Beginner here]

I’m having a problem filling in the Neck on my model. On the head, when I fill, all of the points work properly, but when I try to connect the head to the neck, I get weird criss-cross meshes.

IS there something I did wrong with the Body Mesh?


Turning off the subdivision surface modifier will give a clear view of what you are doing. You may also want to recalculate the face normals by selecting the faces and Ctrl+N

I think you can get better results by using looptool’s bridge, in the tool shelf or W -> looptools -> bridge

@Richard - I turned off Subdivision Surface, but I don’t really know what I’m supposed to be seeing. And Ctrl+N didn’t do anything, as far as I can see. Nothing popped up.

@Uvwxyz - Using the bridge (I didn’t have a looptools subselection, but there’s a bridging option when I press W) gave me the exact same results.

I’ll post a bigger version of the error, with SS turned off.


Accidental Double post, but I’ll edit it with a new question: When you say Normal conflict, what exactly do you mean? I tried using Ctrl+N on the faces in the back, but nothing popped up, So I had no idea if it worked or what it did.

Also, I tested it and the problem extends all the way around the base of the head and the neck, meaning that there’s some disparity between the neck and the head itself.

Usually when a new face does that its a normal conflict. Normal as in face normal.

Bumping because this issue is really holding me back and I don’t know what to do.

You need to activate the looptools-addon for it to work. And you should. It’s great, and even excellently documented .

Normal direction in this context basically means that faces have a “front” and a “back”, and if the normals for the head or body are wrong (turned inside out), tools may have a hard time connecting them as expected.
In Edit mode, in the N-panel, under Mesh Display, there’s an option to visualize the normal directions.
I can’t manage to reproduce your error though, no matter how badly I mess up the normals of my model.

Have you checked so it isn’t an issue with the Mirror modifier? It looks like an error you’d get if the unmirrored head/body were on different sides of the symmetry line.
Remember that Mirror doesn’t just flip geometry from one side to the other - it works in both directions simultaneously. With clipping activated you can’t move anything across the line, but you can create new geometry on either side.

This usually happens when the angle between the edges you try to connect is too big. You should either match them better or you can work around it by connecting one pair of vertices with an edge before you fill the face. This way blender will “know” which verts should connect to eachother.

Still it would be better to just align the geometry better to avoid unnecessary stretching.

Seems like I need glasses. You don’t have flipped faces like in my example but the faces are just connected wrong.
If you still have this problem maybe you could just upload the blend and someone would probably fix it in a few seconds.

The error was that The Symmetry line was different for the Face and the Body, like encn was getting at.

I uploaded both a screenshot of the error and a copy of the file. I haven’t been able to figure out how to reverse the symmetry, without messing up the entire model.


Second21.blend (543 KB)

Indeed encn was right and I didn’t view the images thoroughly enough.

Anyway I fixed it for you.

If you want to do it yourself. Turn of clipping, snap cursor to a middle vert with “shift+s”. Change the pivot to cursor with period “.” and press “ctrl+m” followed by “x” to mirror the mesh on the x-axis. That’s it.

Thanks Ben, that worked perfectly! I made sure to do it myself personally as well and your instructions worked exactly as described.

I’d like to thank everyone for their help because this was really holding up progress for me.

Glad it worked out! :slight_smile: