Need advise\help rendering eyeballs

Hi Forum,

this is my first post ever and I am pretty desperate as I am really new to Blender and cant figure out a seemingly simple issue with Noise and fireflies in my 2 eyeball renders.
I tried millions of settings watching tons of tutorials but could not figure it out.
Basically it is a still image which I want to print out quite big afterwards.
I attached the files (my render fails) and hope that somebody will be able and willing to help me. THX so much in advance floopi
:frowning:
PS
attaching does not work somehow? I can email if necessary.
Or try again later.

Mostly in order to fix noise, the answer is just “render longer.”

You said you have tried a lot of settings, but the “clamp” option tends to be very effective, as well as “filter glossy” for caustics

Using bigger lamps also helps and using more samples of course. You can change the samples in the render settings as well as using the clamp option. You should only use Clamp Indirect and maybe set it to something like 30 to start with. For an eyeball render you could start with 200 samples and then just look how many you need to get a noisefree image (sometimes you need 5000 samples, sometimes 50 are enough, just try it out :))