Need Array Help *SOLVED*


(Guyon) #1

I was doing this tutorial but am stuck

If got to:
Select your brick and add a curve modifier, set the “object” as your curve circle.
HIT APPLY: You can see the shape changing to semi-circular. Yes I can!

I have no clue how to do the next step:
Now in the 1st array modifier, change the fit type to “fit curve”
There is nothing under my add Modifier, and spent two hours trying to figure this out. Is there a better tutorial to do this?

Is there a better tutorial to make an array of bricks around a circle?


(dudecon) #2

Don’t be afraid to click on things, break everything, crash Blender, and start over.
It was there the whole time, if you had only clicked on it.


(JA12) #3

You haven’t provided screenshots and an example .blend of what you’re doing so can’t help with that.

Of course it works in the instructions. They don’t tell to press apply at any point though.


(dudecon) #4

Ahh, good point. If you apply the modifier, it will go away, and then you won’t be able to change the settings any more!


(Guyon) #5

@dudecon I do not see your Fit Type: fixed count.

@JA12 I tried the apply with no luck

If you figure this out please educate me what I am missing.
Here is my small file


(JA12) #6

You had applied and/or hadn’t added modifiers

Attachments

Brick array2.blend (97.1 KB)


(dudecon) #7

Fixed it. You applied the modifiers. You should not have done that.
Here’s my fixed version:
Brick array.blend (75.8 KB)
I couldn’t get it to correctly fit to the curve. Not sure why. Maybe you can sort it JA12?


(Advent Crown) #8

I took a look at the file, there are multiple reasons as to why it won’t fit on the curve. One reason is the same reason that Dudecon pointed out, that you applied the modifiers. The main reason however, is that you didn’t apply the object’s scale. Do that, and your object should properly wrap around the curve.


(Guyon) #9

You guys answers are a little above my head.
So can you break it down a little? I tried to follow the tutorial as best as I could until I hit the vague spot.

@dudecon. what did you do to make it work? I need to know so can make it a second one/ and that one a little bigger


(Felix Kütt) #10

they are all saying the same thing: you didn’t properly follow the instruction, likely because you misread them. Try from the beginning again without hitting apply on modifiers. Instead apply object scales(control + A in 3D view) to make sure all involved objects adhere to 1.0 scale factor.

btw: that very last scaling step in the instructions you had linked applies to the operation in objects local space(edit mode).


(JA12) #11

Ctrl+A -> scale to apply object scale. When the scale is unapplied, it means you’re looking at an object that has different dimensions than its data (mesh), and since modifiers and modeling tools work in object data level, they don’t seem to work properly.

http://pasteall.org/pic/show.php?id=72366


(Guyon) #12

That was amazing. Thank you so much JA12. You should make it a real tutorial on youtube as it is someing not easily figured out. You are my hero.

So I do have a few questions:

Why did you Copy to All Selections? (6 Seconds)

When you Scaled (12 Seconds) what is the rule for when you need to do that?

Again I appreciate the time you took to do this. I am truly would have not done this without you.

Thanks


(JA12) #13

I put the array object to the same location as the curve, so it aligns with it when curve modifier is added

Didn’t scale. Applied scale, ctrl+A, for the reasons I explained earlier


(Guyon) #14

Thank you JA12

Closed.


(Guyon) #15

One last thing. When I tried to move the ring it scaled it (instead of moving). What do I do to make it move? I have not texutred it yet, so will there be any issues adding a texture?


(Felix Kütt) #16

You mean you tried to move the curve object? Try parenting everything to an empty object and moving that.


(Guyon) #17

Thanks Felix_Kütt I will look into that. I never did that before. I thought I read patenting was bad, or was that grouping?

Also I never APPLIED all the mods to the surface. Should I have done that? Or are they usually not applied?


(Felix Kütt) #18

depends on what you need but when in doubt do not apply.