Need for Compute capability 1.1 -version for Linux

There is no Blender version of Compute capability 1.1 for Linux. Some people have compiled their own versions but unfortunately compiling is not an option for me or any ppa-version.

My GTS 250 can’t wait any more. Please help.

Compute Capability is a Hardware feature not a software feature. Just like a DX9 card can’t run DX10 you’r card has CC1.1 and can’t run CC1.2 applications like Cycles.

125 . AlexDS wrote:

“with my GTS 250 1.1 computing i rendered at twice-speed faster (when it worked) than with my i5 720 4-core CPU…”

I have seen some other posts too GTS 250 working ok but it was a while ago.

“does it means that form now on i won’t be having gpu rendering on my machine ?”

Seems like there have been a 250-friendly version of Cycles unless it was working partially at those days and after that it gave only that somewhat dull and too dark rendering result.

I could be wrong and I can’t find it now, but I am pretty sure I read a post in the mailinglist from Brecht that the future versions of Cycles require a minimum of CC 1.2 and for instance the recently added renderpasses require a minimum of CC 2.0

“What is that reason for not compiling” & " What os?"

Ubuntu 10.04 and Mint 12, both are 64 bit versions.

Reasons for not compiling is based on rock solid principles like ‘keep it simple’ and ‘if it ain’t broke, don’t fix it’. Over clocking, optimized builds, and compiling are worth trying but after experinmenting what they are about one should realize that a stable system which is not going to let you down is what we really need. Shortly, I’m trying to optimize my optimizing. Therefore to me ‘compiled versions only’ means that the program is not mainstream and possibly too buggy to use.

If you ever find yourself in a situation that it takes days to find and fix a problem you propably caused by yourself and you are not too happy about to copy paste weird commands to your CLI, tweaking is not for you.

Those principles are efforts to make my life a little bit easier and meaningful.

Thank you again, both of you.

Eppo, I installed that r45133 from Graphicall.org. It didn’t work.


Jurmala… in 2014 you have an anniversary:
“In 1914 swimming without bathing suits was banned.”
http://www.jurmala.lv/page/1076

I don’t think there’s anything more mainstream than compiling the official SVN version of Blender and nothing more optimized than doing it for your machine on your machine.
Besides that, you can just checkout the svn repository and compile a new version every day, even automate it to have the latest features and bugfixes, or you just check out the latest version, like 2.62 currently and compile this one.
Or both.
Or all.

:wink:

Heh… I’ve heard some countries have late 18th century or even earlier ruling in use. Never thought of mine having some. Lol.

You might be and might not be right stating/establishing such rules of peace of mind for yourselves. How comes, you are on Ubuntu, Mint -this ‘Not So Stable Side’? Not on well established ‘That, Other, Proper’ one? No pun intended, not denying anything, still, my mileage shows, roads there are bumpier…
Same goes for Blender, currently in fast pace of development. Thus, i would not expect any rock stability even for a 2.4 series, since a lot of things in its surroundings have changed (and still is). People behind distros, be it Buntus or any other are doing pretty much the same - taking source code of popular apps and making sure they fit in their bigger picture. While they by inertia stick to some ‘tested’ version of that software being overloaded by other problems, nothing prevents me or any other user to grab newer (faster, better, more advanced, well, not so good working or playing together with os sometimes, version and try it out. For my choice of os - Fedora- it sets goal - Blender 2.57, backup contingency plan- 2.49, no feature ffmpeg included for some next release. Lol, I love precautions and stability, but there are limits for that. Its 2.62 out and working here. I dislike constant flow of os updates killing my other functionality more for sure 100% on your side -‘if it ain’t broke, don’t fix it’ (just don’t plug that ethernet wire in).
So i download what Blender developers state as stable source code and do what distro maintainers would plan for next 10 year cycle - compile Blender, check if all features i use work properly and use it. And optimizing goes for hardware i own, not just for a sake of optimizing.
Finding right lines to copy paste in terminal to get at desired goal at the end might take some time, yet when done, gives a lot.
Also, even weirdest and longest lines in terminal at some point start to bring some sense. At the end - if that’s a policy matter, matter of keeping work-group on same grounds - no objections here, just wondering if you’ll be able to work effortless with all the features and tools Blender progress brings right now and soon will be there as a standard.
If in doubt - compile one right now :). It definitely works.

P.S. We do have a nudist part of seaside as far as i have heard… And quite frankly- assuming that law is in effect - i’ve gone against it couple of times ;).
Now, catch me if you can ;)!

@Blempis - FWIW, I think the current unstable (0.9) Luxrender supports earlier compute capability. They’re talking 8000-series nVidia cards in the wiki. I haven’t personally used Luxrender, and it doesn’t look like it is updated as often as Blender, but it might be a path worth exploring, if you are inclined.
http://www.luxrender.net/en_GB/gpu_support

No offence at all, that’s for sure, just kidding. I just did some google search and found this interesting piece of information so I decided to share it with you.

“How comes, you are on Ubuntu, Mint -this ‘Not So Stable Side’?”

Mint is based on Ubuntu. While Ubuntu seemingly went to a direction most users didn’t like. It is not all Ubuntu’s fault, but to me that is not relevant issue at all. While I still have my Ubuntu 10.04 as a work horse, the test bed is Mint at the moment. I won’t risk my work horse by daily builds, but still draw the line between packages and compiling. Ubuntu 12.04 will be supported the next five years. In 2014 there will be another lts-version. Playing with those is my idea of tick-tock. Somebody said that ‘Progress always involves risk; you can’t steal second base and keep your feet on first’ but that’s why there is dual boot :wink:

“I dislike constant flow of os updates killing my other functionality”
Therefore I let go Yafaray and Luxrender and such. During Blender 2.49 it took a long time to make them running. When everything was like I wanted, Blender 2.5 showed up, I couldn’t understand a thing, Yafaray was useless and so on. After experiencing all this (like many others) I decided to concentrate on Blender and Blender only.
“just wondering if you’ll be able to work effortless with all the features and tools Blender progress brings right now and soon will be there as a standard.”

I can’t and I’m still in serious troubles. I bet you know the frustration because you mentioned 2.49. However, if you go with the cutting edge technology, you’ll get all the bugs, incompatibility problems, and you’ll find you way through without any proper documentations; manuals and tutorials. Besides, some features might change and buttons are still trying to find their place every now and then. After a release or two every detail is finally in their place, demos are polished and show what really can be done with the new features, manuals and tutorials, and FAQs are there as well.


Furthermore, I see Fedora as a test bed for Red Hat and therefore won’t have it. Centos might be Red Hat quality and the most stable distro out there, but the community is too small. Debian feels like it has some rough edges but no bevel.

“If in doubt - compile one right now :). It definitely works.”

You mentioned that r45133. I’m interested in having my gts 250 up and running. What should I do? I have compiled Blender a long time ago and followed a step by step tutorial.

I haven’t tested it yet, but it looks like this build for 64-bit linux:


has all the CUDA kernels 1.0->2.1 built.
ls ./blender26/2.62/scripts/addons/cycles/lib/

kernel_sm_10.cubin kernel_sm_12.cubin kernel_sm_20.cubin
kernel_sm_11.cubin kernel_sm_13.cubin kernel_sm_21.cubin

I believe the builder (Fish) always includes all the CUDA kernels in his builds. He makes 32-bit compilations of all his stuff as well, if that’s what you need.

Thanks, Danux.

However, it was the above mentioned r45133 I already tested and it didn’t work.

Some packages were missing. Revision 45133 seems to be made for Ubuntu 11.04 and since then some libraries have changed.

Instead of libavformat52 in there is 53 in Synaptics.
Instead of libswscale0 there is 2.
Instead of libavdevice52 there is 53.

I need 64 bit version.

Edit:
"tested on Ubuntu 10.10 (maverick),Ubuntu 10.04 (lucid),Ubuntu 11.04 (natty), Ubuntu 11.10 (ocelot)"
(Graphicall.org)

Anyway, it didn’t work.

Hi Blempis, try to make symlinks to your libs.
This should work in most cases and you don´t have to change anything in your system.

Cheers, mib.

Eppo wrote: “We do have a nudist part of seaside as far as i have heard…”
Now mib2berlin, about your avatar…

Thanks, mib.

I’m not familiar with symlinks. Open terminal, man ln - that’s all I know at this point.

This is really weird. Why does CUDA work with CC <1.3 in GNU/Linux but not in Windows? I heard several people now, saying they get AO and passes on GPU in GNU/Linux using GPU with older cards but my GTX285 doesn’t work in Windows, rendering works, but not AO, shadow, normal passes and all that - and this is as you need CC 2.0 for that… But somehow it works in GNU/Linux…? Weirdness.

Hi mib2berlin,

I didn’t have Blender (2.58) from repository installed. Now it is installed and r45133 opened as well, but still no luck with gpu.

This symlink operation is going to take some time. If you already have an idea how should it look, could you give a hint (code scetch if not accurate).

Ah, if it start you don´t need the symlinks.
Could you see you gfx card in User Preferences > System > Compute System > Cuda ?
If yes, mark your card and set Experimental in Render Settings > Feature Set.
It is possible you have to copy the render kernel from your downloaded r 45133/2.62/scripts/addons/cycles/lib to
./blender/2.62/scripts/addons/cycles/lib/

Cheers, mib.
@Farmfield, I´ve tested ao and shadow pass again with a CC 1.3 card, don´t work for me with latest svn build.
IIRC i had a build where it worked, but dunno which one. Anyway, time for a new Card.

Mib,

Thank you!

Ok folks, this was it (for Linux Mint12):

  1. Make sure that you already have Blender installed from repository. Without that r45133 didn’t start at all.
  2. Install r45133 from Graphicall.org .
  3. Start Blender (r45133).
  4. From rendering panel find “Feature set:” and use “Experimental”.

Happy .blending

Tnx mate, good to know. And looks like I have a GTX580 coming in the next few days now, hopefully… :slight_smile:

So you did catch me :)? Nice, glad you managed, despite methods being beyond imaginable…However, if you had no previous ones, just 2.4x - outdated python?
Well, actually i did took a deep breath and compiled latest from svn - r45384. And you know what - all the goodness works again, Layers, AO, Cycles ColourRamps added…
cc 1.0. GF9800GT

Hi eppo, can´t get a ao pass out of blender r45358. (Where do you get r45384? :))
Do you have a small test file with ao pass?
Do you use Cuda Toolkit 4.0, 4.1 or 4.2?
Which driver do you use?

Thanks, mib.