Need for sculpting speed...

Title says it all. How can I achieve better sculpting speeds?

I have Windows7 64, nVidia GTX295, Pentium i5, 4 GB Ram and my PC performs very slow on sculpting.
Currently I use builds from (like dyntopo), also other builds like the main branch.

A pure example is this sculpt, where I opened it at my computer and it’s impossible for me to work on it due to heavy lagging. I wonder how this artist managed to work on this level… (See for yourself if you can work on in fast speed)

Another example is a sculpt I -try to- work on has 219440 Vertices and 219438 Faces, but it’s impossible to do do even the slightest doodle on it due to lagging issues.

P.S. I have tried also setting Cuda and VBO from preferences but no difference.

Anyway, I have no problem to buy new hardware (eventually some time in the future it will happen, it’s unavoidable), I am just investigating about this subject what other users feel about it. I would like to hear your opinions.

Try this :
-do not use Textured mode , use Solid mode for sculpting, you’ll not be able to use those nice matcaps in GLSL display, but the gain in speed is very huge

  • select the model and in the Object Data panel, make sure “Double Sided” is NOT enabled, (by default for every object you add it will be enabled), it’s a big performance killer, and even more for people with recent nvidia cards

  • if you use a Multires modifier , add a “Simple Deform” modifier after it with the Factor set to 0 so it does nothing or a Curve modifier with nothing selected in it. This is because it has been reported that apparently if you have a Multires modifier and it’s the only modifier of the stack it will impact performance more than if there’s another modifier (doing nothing) after it.

  • Press N to bring the N panel to your right, scroll down until Display and disable “Outline Selected” , Outline selected apparently make a copy of the existing model to display the outline around the selected model and so consume more ressources, you can enable “Only Render” there to get rid of everything else.

-In Object Mode, select the model and click on Smooth in the T-Panel to the left, it is said that having the model using Flat shading consume more ressource than in smooth shading.

  • Hide part of the model in Sculpt Mode, hold the H key and box select part of the model you’re not sculpting on to hide them, it improves performance, sometime a lot, ALT+H will unhide everything (both functions can be found in the sculpt mode menu)

  • in File -> User Preferences -> Editing : disable Global Undo and lower the amount of Undo a lot.
    Undo apparently save the model in memory, eating ressources, so the less undo you have available, the less it should eat your system ressources.
    Enabling VBO seems to be a must too apparently , as on my system the difference is barely noticable.

It will provide some slight improvement, but there’s no miracle to expect unfortunately unless you have a very expensive system and graphic card.

The best bet for pure performance is when Dyntopo will be improved and become stable, as it will allow to add very fine details without having to increase the whole model polycount so much that it will cripple brush performance.

But if you want to work on a sculpted model that has had its multiresolution modifier applied, Blender will make it a real pain unless you have a powerfull system and state of the art expensive graphic card that has greater opengl support .

I always found odd that Blender with OpenGL hardware acceleration it is using is so much slower than Zbrush that display millions of faces smoothly even on weak computers and that do not even use hardware acceleration from OpenGL or DirectX.
There are some people claim they sculpt on a dozen of millions of faces smoothly, though i never got more than 500k being smooth, at 500k i start to see the brush getting some difficulty, at 1 million it seems the limit of workable for me.

Wow this is amazing I tried your advice and I saw amazing speedup.
Very helpful post I recommend it to everyone that want more speed (and does not want to upgrade his machine of course)… :slight_smile:

Also: What gave me the biggest sculpt improvement was changing the “Window Draw Method”

As shown in this video:

This video was made for 2.5, but applies to 2.6x as well!

Just pick the one that gives you the biggest improvement, and don’t trust automatic to pick the best :slight_smile: