NEED HELP!: GPU cycles rendering problem

I’m very new to blender and i just got a new GPU (AMD Radeon RX 580) to improve rendering, EEVEE and everything else works totally fine but if i try to use Cycles everything in the view turns completely grey, if i instead use my CPU for cycles it renders normally.

CPU render

GPU render

I tried looking online for what the problem might be but i couldn’t find anything matching my problem, and the few similar ones i found didn’t give me any useful solution for this.
Has anyone had a similar problem? if yes how did you solve it?

Have you tried adding lights? Make sure they are visible too.

Maybe this will help,
This^ may not be relevant because that doesn’t look like a heavy scene but you can look around on that page.

I think though people are gonna need a bit more information. What OS, do you have the most recent driver?

I think this is the right page for the driver, but if you don’t have experience with installing drivers you may want to get more assistance. You can read the information about the driver like the release notes. See if you can find on your system the version driver you have.

Hope that is of some help.

My OS is Windows 10, and yes, i have all the most recent drivers, or at least that’s what the AMD software says, unfortunately i’m still lost on what the problem is.

Well I don’t think I’m gonna be of much assistance but I have a couple of ideas…

What happens when you toggle the cpu on in the opencl settings?

What happens when you render (f12)?

When i toggle CPU nothing changes, meanwhile if i render an image it renders as if everything was fine.

with the gpu right?

yes, everything is there when i render an image.

Looking back at the original images maybe @81U3 is right. I see in your outliner your light is off while I am assuming that the light is on for rendering. Try toggling that eye icon next to the light.

edit: other than that I think I’m out of ideas I hope someone comes along with more experience, I am running linux with an nvidia card.

I already checked the light, nothing changes.

I might have a few more ideas…

Can you show a screenshot of your radeon settings?

It might be something to do with the file itself/settings somewhere. Are you able to upload the .blend?

Guys i think i (kinda) solved it, i installed a previous version of blender and now it seems to work fine.

Thats good, at least you can work.