Need help. Grainy dots in render.

Hi, as you can see in the screenshot below it’s quite grainy no? Why is this? At first I thought I didn’t put some render options high enough but still it shows the grainy-ness with high settings. I’ve pumped up the resolution to 100%, put anti-aliasing on 16, fiddled with the tiles setting, and a few other things. I haven’t rendered in a different file format though, I rendered this image in PNG. My computer is a low end machine and it takes a long time to render even small things, so I can’t keep rendering and rendering trying to figure out on my own what’s wrong.
Can anyone guess what’s wrong?

I’ve tried uploading the blend file but it keeps failing.

Thanks.


Is this rendered in Cycles? How many samples are you using?

I would bump AA up to around 36-49 samples.

Yes, this is rendered in Cycles. I used 100 samples. And the tiles were x:64 y:64

What’s AA?

Anti-Aliasing. Helps drop the graininess in shadows when you increase the anti-aliasing samples. If you’re using a progressive render, I would increase it to at least 300 samples or more.

I put the anti-aliasing setting on 16 under the OpenGL Render settings is this what you mean? Also under Sampling I should put the render samples to 400?

P.S I’m new to blender :slight_smile:

Oh the blend file didn’t fail to upload this time here it is:
Blender Dog Tag #Share .blend (411 KB)

No, you can set AA samples separately if you turn on Branched Path Tracing in the dropdown in the sampling panel. If you’re just beginning, though, I’d stick with normal path tracing. Just increase your samples above 100. You need more to get the result you want.

That .blend file looks nothing like what you’re showing here. It has a dogtag, and that’s it. It’s also has no camera and is set for BI not cycles.

Dammit! Wrong one sorry. I’ve tried now uploading the correct file but it keeps failing… I’ll try again later.

Ok; here’s the file… for some reason it keeps failing the 4mb upload so I’ve put it in a compressed folder.

My Emblem #40 Share .zip (1.41 MB)

Attachments

My Emblem #10.blend (476 KB)

Ignore the second attached file… I never attached that one but it’s here for some reason… “My Emblem #40 Share” is the one.

All I did was increase the samples to 400 and set teh tile size to 16x16 since I render on the cpu.


Yeah! This looks nice. What is the grainy shadow on the lighting blot in the back, on the right side of the eagle’s wing? Is that normal?

More samples will cure that also. I would bump it up to 600 and give that a shot. Or checking No Caustics may fix it.

Ok; thanks!

Not exactly a lighting/rendering thing, but there are some strange things going on with the geometry in your scene:

  • Most of the normals are flipped (= pointing inside) and
  • it seems you’re adding the Solidify modifier to meshes that already are solid (= wonky geometry in some parts).

Just saying…

LOL I added a Solidify modifier just to thicken the objects… they look fine to me, thanks though :slight_smile:

And that doubles the geometry for no reason. Remove solidify, edit mode, select all, W -> remove doubles, ctrl+N to make normals consistent and pointing outside. Alt+S to shrink/fatten.

Not every object has a material and smooth shading. Could use a default diffuse shader for those and tool shelf has smooth shading button. Enable multiple importance sample for spot light.

I tried branched path tracing after those settings. I used world settings to give ambient light and render settings are visible in the screenshot. Top: Render result. Bottom: Result after poking it with compositing.


Ok; thanks! To shrink/fatten things, Alt+S, is there anywhere where I can put in a value? It’s kind of hard doing it by mouse.

Also, I might not have pressed the right button, but I can’t see any option to change to Branched Path Tracing…


Yes you can type in value after you press alt+S. See the 3D view header.
You have older version of Blender. Those settings become visible when you turn off progressive sampling in 2.68.