Need help in identifying problem

Hi. I’m currently following a tutorial series on modeling a Tim-Burton style character, but I’ve run into ‘problems’ with my model’s eyes currently.

I’m not so sure how to describe it but here’s an image to (hopefully) give you an idea.

  <img src="/uploads/default/original/3X/3/2/327c595220a51fd649bd151d6d1207eb11058eab.png" width="690" height="388"><br/>

(http://i.imgur.com/KzuBy.png)

  It seems that my model's eyes are stained with the skin color and  I'm not even sure why is it so, too. I thought it had to do with the  texturing at first so I tested with an all-white texture. But I got this  result:
  
  <img src="/uploads/default/original/3X/1/5/1591f40e1d152d56bed43be90bb8c28060e31f51.png" width="690" height="388"><br/>

(http://i.imgur.com/NCIZI.png)

  So the problem definitely doesn't lie with the texture. I'm  honestly not sure what I've done to get this horrifying problem, and am not even sure if this is an <i>actual </i>
  
  Would really appreciate any help I could get! I'd be willing to post my .blend file if anyone needs it to identify the problem.
  
  Thanks!

It looks as though you have reflectivity assigned on the material settings? I’m certain theyre picking up reflection colors from the skin surrounding the eyes.

In the tutorial i just took from jon Williamson, he has us do the eyes without reflectivity, rather we paint on manually a reflective bright white dot into the eyes when we are painting the UV’s in gimp/photoshop. I would suggest trying that and removing reflection from the eyeballs materials layer. . . it may solve your problems.

That is of course you have reflection turned on!

White dot on the eyeball is really a specula reflection you know. It is not the same as mirror reflection. Make your specula setting high and sharp to get that. If you want “reflection” on the eyeball, use gray white as a reflection color.

Thanks for the replies.

walldiv was right. I simply unchecked Mirror under Materials, which had reflectivity and the problem was completely gone.

Thanks for all the help! :slight_smile: