Need help on strange artifacts in Viewport

Help! why do I see all of those rainbow dots? I know its not noise. It seems to disappear when I put a cube overlapping the plane please help me! by the way, I just updated to 2.8.1

!

Could you maybe provide the blend file? So I could look at it. :slight_smile:

Looks like I can’t. it says new users cant upload attachments.

You can upload it here if you want.


:slight_smile:

Here: https://ufile.io/wj6u6w9m

I am missing the textures you have been using. You need to pack all of it into the blend file.
It is under File/External Data/Pack All Into Blend File or use Atomatically Pack. Then save it and upload the file again. :slight_smile:

Sorry for the wait the upload took a bit for using 8k textures. Here it is once again https://ufile.io/hk2aq667

Well, I’ve looked at it and I have no problems of any kind. Tried Eevee, Cycles.
I also tried rendering with CPU and GPU no artifacts. :thinking:

What are the specs of your setup?

What do you mean by that?

Earlier when i render in eevee i did not see any artifacts only in the viewport when i select viewport shading. not even on viewport render image i see it

What CPU and GPU do you have? That is what I meant when I said “specs”. :slight_smile:
Maybe you have an outdated graphics driver or maybe you’ve encountered bug inside the 2.8.1. I have personally never seen anything like that. I also wasn’t able to replicate it. :thinking:

Looks like Graphical glitches

Check your drivers

Try the 2.82 alpha

I dont see the artifacts in blender 2.8.0 only 2.8.1

My cpu is intel celeron N3350 i’m really sure i use a intel hd graphics 500 gpu.

So as I can see you are probably using a notebook.
N3350 CPU 2 Core 2,4 GHz Max
and Integrated Graphics Intel HD 500 running between 650-700 MHz which lacks dedicated graphics memory.

You are using an 8k texture inside of your project. I guess your notebook is just giving up when it tries to render it. :thinking:

But you said that you don’t have those issues in Blender 2.8.0. Why not just use that version for the moment? At least until you find out why you have those artifacts. :slight_smile:

When i render it i dont see the artifacts it only in the view port. i think a also seen it before with another projects that dont use 8k textures. And i use windows 10

I changed the texture for a normal image that not 8k but i still see it. And for some reason i dont see it in material preview mode.

It might not be applicable to you but

my surface pro 3 would show a frozen viewport with the shipped graphics driver by microsoft.

which is solved only after I installed an updated one via device manager

I would try restarting my machine. see if that works. probably that happened because since the other day my laptop stayed in hibernation and not off.

Viewport is still rendered, just involves the fixed function pipeline of your GPU, which is likely having the issue.