Need help on strange artifacts in Viewport

Disable soft-shadows. ( or keep soft-shadows but enable high bit depth ) i have the issue you have in 2.82 … maybe worth reporting to Dev.

I did work!