Need help selecting vertices, edges, and faces

I have to be missing something stupid simple here, but I have imported a model to Blender. I am in edit mode and have tried clicking the boxes for vertices, edges, and faces to attempt to edit said features on my model. However, it will not let me click on any of those features on the model. Every place I have tried looking online simply says “select the face you wish to edit…” or other some such thing without actually saying how to select them. I have tried every combination of left-click, middle-click, right-click, shift, alt, and ctrl I can think of and no dice. As I’ve said, I’m probably missing something stupid here, but any help would be appreciated.

In a default Blender setup selection should be on right click. If that doesn’t select the component you’re hovering the mouse over, there might be an issue with your graphics driver.

Hit Ctrl-Alt-U to open the user preferences and try using another selection method:


If you found something that works, don’t forget to save the user preferences to make that permanent. Make sure your graphics driver is up to date.

By any chance… What exactly was the process you “imported” model?
Was it like File - Link?

Does selecting and editing of default Cube work for you normally?

I’ve tried changing the selection methods in the preferences menu with no change. For the model I was trying to work with I did File>Import>and selected a .OBJ. I can see all the polygons and can even select the entire model but can’t click anything else. Even with the default cube, I can select the entire object but no vertices, edges, etc. Probably graphics issue then?

Are you in Edit mode (TAB key)?

Show us screenshots of the whole blender interface while you are trying to select something
Attach or supply a link to your blend file.