Need help to set a proper scale

Hello.
I’m a Blender newbie in search for help from some more experienced Blender users. I’ve searched the internet already but didn’t find answers to all my questions, so I’m trying my luck here.

Here’s my problem.
I am currently working on a rather big terrain that needs to be exported to another program.
While I am aware that units don’t matter when you model, because everything only has to be in the right scale relative to the other objects, this causes a lot of inconvenience and loss of accuracy when exporting the heightmap to the engine it’s meant for.
When I render the heightmap in Blender, it makes the lowest point black and the highest point white,which is normal and perfectly fine. However, it also means that the information about the scale gets lost. When I import it afterwards, the engine can only assume that black is 0 meters and white is the terrains max. height, which I can configure.
I cannot know how high the highest point is, because the scales don’t match. While I could find out the factor to calculate the necessary value, this is not possible because I’m not recreating something, but creating something myself.
In other words: I don’t even know how high that mountain I’m creating is myself. At least not accurately.

In order to be able to easily tell how high a certain point is, edit accurately and export/import without screwing up the vertical scale, I want to work with the same scale in Blender.

Here is the data from/for the engine:
-Heightmap is 8192x8192 px in size
-Heightmap scale is 1:1 (terrain is 8192x8192 meters big)
-I’ll be using roughly 6x6 km from that

What I want to achieve in Blender:
-Plane that is 6144x6144 meters big
-In the end, it will be subdivided into 6144x6144 smaller parts (each part will equal 1 meter and therefore 1 pixel then)

I just can’t figure out how to do this. The view get’s clipped, the grid stays small and I’m not entirely sure if this is a good idea to begin with.
Could this cause problems with Blender, its tools* or rendering?

*This is important to me. Do the “tools scale”. If I wanted to move a certain point up by, let’s say, 200 meters, would I have to move it millimeter by millimeter? I think I’d go crazy.

I hope that you understand what I want and can help me.
Thanks.

Not sure if this will help since I don’t do things in that big of a scale, but try this: Open the “n” panel if it’s not open already. Scroll down to the “View” section. In the area that says “clip” change the Start & End values until the view isn’t clipped anymore. I think the default is 1000 units (Blender units). I changed my default scene to use meters instead of Blender units, so I have 1KM as my “end” value. Hope this offers some help.

Thanks for the answer.
I made a copy of my terrain and messed around with the various settings for some time.
The conclusion is that you can not, or better should not, work on such a scale.
You can set everything up (metric units, size of the plane, view clipping, the tools), but you won’t be able to render a heightmap that’s +4000 meters in size. This is due to the camera. The orthographic scale is capped at 4000. I just couldn’t fit the entire plane on a single rendering.
The easiest option was to divide by 10. Instead of a (let’s say) 4096x4096 m plane, I used a 4096x4096 dm plane.

I also found a simple way to get the scale right in the engine (CryEngine).

  1. Take one random point (preferably an edge), select it in Edit Mode and move it underneath the lowest point. Let’s say the lowest point is -8.897… Move it to -10.
  2. Take another point and move over the highest point of the plane. Let’s say 250.
  3. Render

Now you have a black and a white point on your rendering that you know the exact height of. Before importing it into the CryEngine, set the terrains max. height to the difference (260m) and import it.