Need help, very frustrated.

Been trying to model this guitar for a while and whether there are triangles, or quads i keep getting the same problem with the normals. Here is what is happening. Sorry for double posting pretty much about the same thing, but the guitar body is fine now, its the neck thats giving me problems

Any suggestions? Tried subsurfing, smoothing, CTRL + Ning, and nothing has fixed it

Select them all then press CTRL + N and then see what you got.

the pictures you see is what happened after i pressed ctrl n

well with all the points selected hit w> remove doubles. then try again

same problem still =S

Can you post a blend file so we can look at it?

heres the .blend for ya


stratocaster.blend (236 KB)

If recalculating normals doesn’t fix your problem, you have a non manifold mesh.

This is not necessarily a problem, because it is often not visible in a render (depends on the texturing and lighting). If on the other hand you plan to UV map the object it is definitely a problem.

  • First thing to do is to remove doubles. I think you have done that.
  • Make sure you have selected all vertices before you recalculated the normals.
  • Now select the non manifold vertices (Select-Menue). If you have interal faces, remove them.
  • There are models that are necessarily non manifold, then you have to flip normals by hand, and hide the seam someplace where it is not so obvious.


Yep, you have internal faces. Remove those, and you’re done.


stratocaster.blend (66 KB)

A small group of faces where the neck attaches to the body do have normals pointing inwards. Select just those faces and flip the normals. To see normals open the Mesh Tools More panel in Edit context F9 and enable draw normas. You’ll see that a few faces don’t appear to have normals because they are pointing inwards.

alright, got it, thanks for help, been using blender for about a week so still a noob at this point ^^