Need help with Andrew Price's flame-thrower tutorial...

Hi guys,
I’m trying to render Blender Guru’s flame-thrower, however with not much success when it comes to flames. Whatever I try, they still show as a bunch of colored M&M’s flowing from a faucet… (see image)
Anyone knows how to get something correct ?

Attachments


Get your camera closer, so we can actually tell what is going on in there. The camera is so far away that it is impossible to see it…

haha why didn’t you zoom in on that picture? its so far away and with a ton of black around it, its almost impossible to even make out the problem you’re describing!

anyway, to answer your question, if the flame looks like little balls, its potentially because the smoke/fire is combusting too slowly (the ‘fuel’ is being emitted from particles and just sitting there rather than burning). in your domain object, try raising the ‘density’ and ‘temp. diff’ values.

good luck!

Ouch, sorry about the size of the render…you’re both right, there’s nothing to see up there…
@shteeve : thanks for your tips, I’m checking on that right now. I’ll post the outcome in a minu… well, make that when my CPU has come out of coma. :eek:

increase the smoke resolution

Well, thanks again for your suggestions, however, my flames still look like beads.
@Idh1109 : I did increase the smoke res to 100, but the result does not change
@shteeve : same with raising “density” and “temp diff”, it does not look like it changes a thing, apart of multiplying the baking time…
here is the best I can come up with, I’d welcome any suggestion …

Attachments


Maybe increase the amount of particles being emitted?
Other than that I have no idea what’s causing the problem :frowning:

thanks, Sam M, but nope, I’ve already tried setting them up to 100’000 without any noticeable improvement… apart again threatening to kill my computer :no:

but nice try, thanks again !

Can I see the .blend? Could be something simple as Anti-Aliasing, or a button that’s unchecked.

ah much easier to see with the better render. in the material tab for your domain object, go to the ‘integration’ settings and try lowering the step size. it should be something low like 0.2 or 0.1, but if its already there, try 0.05 (if your computer can handle it)

Hey, once i saw on another tutorial of Andrew, that was how create a Explosion in blender.

This trouble thas is happening with you happened with andrew too, if you watch the tutorial i think you will discover how to fix that

Here is the link:

http://www.blenderguru.com/how-to-create-an-explosion/

@all : I’ve got it, and Andrew Price (Holy Guru) wouldn’t be proud of me … the problem does not reside in the particles themselves, but in the way they show in the final render : and there comes the famous compositing (ta-daaaah). So much for not following the whole tutorial before crying for help…
Not only does it smooth the particles, but it can cast a glare around the flame, etc… and all this without multiplying by umph the baking time, as it has nothing to do with it…
“After Darkness comes Light”
feel free to comment or critic the render below, it’s only what now should be directed to the WIP section (or was it since the beginning ?..)
thanks to y’all for your help and support !!! Merry blending ! See you in the WIP section, if I find some time…

Attachments