need help with blender and makehuman

hi there i need help with blender2.54 and makehuman 1alpha 5. at first i couldn’t export from makehuan as a .mhx but found a solution to that by placing # in certain places. next i went into blender trying to import my .Mhx file but when i do it dosent do anything but this code pops up in the black blender code window.

also the import.mhx script is version 0.9.5 alpha. so please help any help is welcome.
Thanks in advance.

Downloaded the latest … for Windows.
using e to make an obj file worked and I could import it to Blender … and too the bhv for the bones …
using the mxh addon (on an older mxh) gave the same error as you showed …

ok so under further inspection i found out that my import .Mhx was out of date i put the new uptodate made for 2.54 import .Mhx in and this comes up now

the first thing saying how it is version 0.9 is wrong i checked the script with python and it says that it is version 0.17 so it must be a glitch. and i got the import .mhx from the most recent nightly build.

PKHG thanks for your advice ay got any more advice.
thanks in advance

Made with version of today (obj en bhv):

PKHG did u put in your own armatures or did they export with the model since thats why i want .Mhx working since the exported model contains armatures which are probably better then what i can make.

thanks PKHG

All imported from a ‘make’ with makehuman (obj. and bhv) :wink: (makehuman W32 downloaded today)

To know is this:
the bones have to be rotated x 90 and s 10 to fit the mesh …
(colorized by vertex painting)


You must download a new version of MH and export your character again. It is not enough to have an updated version of the importer, but also of the mhx file itself. The mhx file contains statements which depend on Blender’s python api, and thus become obsolete when the api changes. Hopefully the api will be stable from here on, and this kind of problem should belong to the past.

Sorry, I downloaded THIS morning MH, and there is at this moment no mhx export implemented (only obj en bvh)
Maybe you run a Linux version or OSX?

nah i used the makehuman alpha 1 on PC

PKHG you are a god i did what u said with getting the armature through .bvh and obj and it worked thank you so much i gess ill just wait till make human decides to settle down until i try to get .Mhx working again thank you again PKHG and ThomasL

not to hammer on makehuman
respect their work as well

depending on your pressure I found Daz 3D Studio a very good alternative as well.

I run MH on both Windows and Ubuntu without problems. Usually I use the version in svn, but this morning I tried nightly builds from , without encountering any problems. Download a nightly build, not alpha5. However, some trickery is necessary to make the importer work, because there is a conflict with the version that comes with blender. See . I will ask Meta-Androcto to update the importer, since the version that comes with Blender was written before the big API renaming and thus is unusable anyway.

How to remove this error:
Traceback (most recent call last):
File “./mh_core\”, line 1411, in mouseButtonUp
self.application.mouseUp(button, x, y)
File “./mh_core\”, line 476, in mouseUp
self.mouseDownObject.callEvent(‘onClicked’, event)
File “./mh_core\”, line 93, in callEvent
getattr(self, eventType)(event)
File “./mh_core\”, line 925, in onClicked
File “./mh_plugins\”, line 201, in onFileSelected
mh2mhx.exportMhx(, os.path.join(expor
tPath, filename + “.mhx”))
File “./mh_plugins\”, line 46, in exportMhx
print("Writing MHX 2.5x file " + filename )

Some option or some Python version to use???

The problem is a non-ascii character in your pathname, see .

It also looks like you are using alpha 5. This is quite old and its mhx files can no longer be imported into Blender, due to the api renaming. If you are using svn or a nightly build, something is wrong, because the directory mh_plugins no longer exist; is now located in apps/mh2. Install a nightly build, and make sure that there are no old .pyc files around. They are not under version control, which can cause a lot of confusion.

yay thank you for evryone who gave infomation but i did not realize why the alpha 5 wasnt woring it is becasue it isnt up to par with the nighlies anyhow thank you so much it actually let me export as .Mhx to blender without any problems.
so thankyou all for helping me and anyone else who may have these problems.