Need help with Cycles rendering times on this scene

Hey there!

I got into a little trouble here. I have this job (to be delivered in a couple days), but I didn’t expected a scene so simple would take so much time to render in Cycles. I mean, no textures, no complex materials, no reflections… I only use one kind of material, which is a diffuse color with a little gloss mixed in. These objects you see

The background is an infinite white backdrop, which I made in the shape of a big white bowl so I can turn the camera around. I use two suns as lighting, sized properly to get this soft lighting and diffuse shadow.

I have set up different sampling, light bounces, I researched a little… but I bet there’s something obvious I am overseeing. I find it IMPOSSIBLE for this scene to require about ONE HOUR to render a single frame on an i5 notebook, and more than 20 minutes on an i7-CPU.

Plus, I know my Geforce 550 Ti is not TOP of the line, but even so… GPU rendering times is even worse!

Please could you guys take a look on the scene and tell me what is wrong about it? Is it the DOF, or maybe Motion Blur?

I appreciate your help!

I am attaching the blender file and a rendered frame.
(Sorry for the ZIP compression. The forum didn’t let me upload the .blend file of about 2 MB. I’m not very experienced here).

uniclivale_ba.zip (814 KB)

Attachments


All because of this giant bowl.

Haven’t looked at the file yet, but seeing the image you posted I think you’d do better using Internal instead of Cycles for this project.

I’ll check the file anyway and see what can be done to reduce render times :wink:

Rendering your exact file takes my machine around 25 minutes/frame. (I didn’t render an entire frame, not enough time, sorry!)

I agree with the above post that BI will probably get you a faster render. But it also sounds to me like you don’t have time to make that conversion. I was able to get it down to 1 minute 34 seconds in Cycles. Note that this does involve some compromises, which is pretty much always the case when you’re trying to manage render times.

Here is what I did:

  • I reduced your render size to 75%. Scale it up later (in After Effects e.g.), add a little sharpening and a little grain, it will work.
  • Your squares have diffuse and glossy mixed. I removed all glossy elements.
  • I reduced your Render Samples from 576 (24 squared) to 64 (8 squared). I also changed from Path Tracing to Branched Path Tracing – I set all Samples to 1, giving 64 samples for each.
  • I reduced your Light Path bounces dramatically. Also disabled Reflective and Refractive Caustics, though I don’t think it matters once I’ve removed all Glossies.
  • I reduced the Max Bounces on both your sun lamps from 512 to 12. Also turned off Multiple Importance.
  • For your environment, I disabled Multiple Importance.

I probably did other stuff, but that’s what comes to mind as I ran through everything quickly.

Resulting blend file here: http://www.pasteall.org/blend/42259

Good luck!

Thank you very, very much for taking this time and helping me so quickly! Your comments and optimized file was most enlightening.

I noticed you didn’t really removed 100% of the glossies - what gives me the idea of removing all but a few (keeping just the few ones in the foreground and only when this glossy/slight reflection really matters).

Thanks again, I’ll post how I did later!

you might also consider using experimental denoise branche, so you can render wit even lower samples and still get good result
i was able to render with just 40 samples and couldnt spot a difference. that took me about 3 min p frame i7 octocore. 2.3ghz

I could also go as low as 10 samples by changing your light setup to “direct light”, with this build and that did the trick in about 1 minute. (but not sure if that would change what you want to much) but at your size i think ~1 minute = fast