Need Help with Fluid Particles

I am not sure why the fluids are sitting above the floor.

  1. Shows the domain object and it is sitting on the floor
  2. Shows the particles when they are baked and they are not sitting on the floor
  3. I have a plane object (obstacle) and it is sitting above the domain 0.005
  4. Shows how the particles look above the table.

Any ideas why (see image 2) why the fluids are sitting so high in the domain? How can I fix this?


i think it is because low resolution of domain grid. try set higher value

(or if if youdont wan to take resolution higher (its time consuming) just move domain lower :slight_smile: )

thanks vklidu.

I moved the domain down a little and it helped. Here I want to pour a liquid into a cup. I’ve read that unless you have thick walls on your obstacle (cup) then the liquid will pour through as you can see in my image, but a really thick cup isn’t realistic.
I’ve seen Blender images with thin walled obstacles and the liquid is not pouring out. How is this accomplished? There must be some settings to do with the obstacle, fluid or domain that can help fix this?

Volume Initialization: Volume (Volume, Shell, Both)


maybe a thicker cup around it, that’s not visible in the render will help?

Good idea I’l give it a try.

The fluid stops flowing and I don’t know how to make it flow more continuous. Any help is appreciated. :slight_smile:

Do you know how to make the fluid flow continuously? I am using a “Fluid” for the fluid type but whenever I select “Outflow” for the fluid type instead of fluid it says it can’t render because the fluid type is not set to “Fluid”.

Also in the Domain Settings what are the “Real World Size” settings for? And do larger values increase render times but give more reality? please explain if you can.

I think its a good time to look for some tutorials :slight_smile:

Trust me I’ve been watching a few already. :slight_smile:

Also in the Domain Settings what are the “Real World Size” settings for?

Size of the domain object in the real world in meters. If you want to create a mug of coffee, this might be 10 cm (0.1 meters), while a swimming pool might be 10m. The size set here is for the longest side of the domain bounding box.

Increasing the size will increase baking time.

Richard, thanks for the link. Just going over the wiki right now.

One question I don’t see in the WIKI is where the default “/tmp/” bake files are stored. When I am baking all of my fluid tests are they storing the files somewhere in my Hard Drive. I am on a mac and I can’t find the “/tmp/” folder anywhere.

Bake Directory
The default value is “/tmp/”, which is probably not what you want.

The /tmp/ folder is the Macintosh HD/private/tmp folder. This is a hidden folder but you can show hidden folders with this dashboard widget
Just change the location to a more convenient location.

I have had exactly the same problem as per first post, I have found shell works best not sure but normals seem to be issue as well.

Thanks again Richard. I downloaded and ran the app. Funny thing is my desktop is so cluttered I couldn’t see any /tmp/ files except maybe 2 which I deleted.

I thought that blender saved all of the baked resources when you bake a domain to the /tmp/ folder and I was concerned that this /tmp/ folder may be getting huge, but I don’t think the /tmp/ folder stores the previews when you bake a domain but I can’t be sure.

When you bake a domain does it store the information anywhere as far as you know or does it only store the files if you create a directory in the Render window?

You can easily get to the tmp folder on a Mac. In the Go menu of the finder choose Goto Folder; in the box type in /tmp/ and press Go. You can drag it into the side bar for easy access later.

Alan, thanks for that. Didn’t know it could be so easy. :slight_smile: BTW, there were no big files in there from doing domain previews.