Need help with setting up Armatures...

Hi everyone…
im making my first character person from this tutorial - which although good - is unfinished:
http://mediawiki.blender.org/index.php/User:Marenzelleria/Tutorial_Index

I have rigged the top half of the body, but after connecting it to the body, nothing seems to work properly… and the tutorial cuts off just before this part…

the arms / torso / head do no ‘bend’ properly, and parts of the mesh stetch.
i have tried vertice groups and envelopes but i cant get it to work…

can anyone help?

blend
http://users.bigpond.net.au/benger/blender/person.blend

screenshot
http://users.bigpond.net.au/benger/blender/person.jpg

much appreciated…
benger :cool:

That was an unfortunate place to end that tutorial !

Like one of those 2 part t.v. shows … that you don’t know are 2-parters till the end of the show :slight_smile:

Anyway, the reason your mesh/body is messing up, is because the vertex groups haven’t been assigned properly … or at all … for the majority of the mesh.

After you’ve made the settings on the Weight Paint panel as per the tutorial, RMB click on any bone in the armature. Then make sure you are in Pose Mode for the Armature, (CTR-TAB)(or choose PoseMode from the) menu.

** Note** that CTR-TAB has two different uses depending on what is selected. If an Armature object is selected it toggles Pose/Object mode, while if a mesh object (like your Person body) is selected, it toggles Weight Paint/Object mode.

After you are in WeightPaint mode, the procedure is to RMB on a bone, then LMB drag(paint) on an area of the mesh you want influenced by that bone. If you keep ‘painting’ an area the color will change to red eventually meaning that the bone is fully influencing that area of the mesh.

Once you’ve painted all your weights, press CTR-TAB to return to object mode (for the mesh), then RMB select a bone and g(rab/move) or r(otate) it to see the effect on the mesh.

Instead of / in addition to weight painting, you can RMB select the Mesh (in Object mode), go into edit mode and pick a vertex group from the vertex groups panel on the edit buttons. Then press Select, to check which verts are assigned to that group. Press ‘a’ to toggle all/none selected. Press Assign to assign more verts to a group, Remove to remove verts from a group.

You’ll probably want to assign the eyes to the Armature, and weight paint them as well.

Mike

thanks for the help.
it all works now :slight_smile: