Need help with smooth edges


I’m stuck trying to getting a smooth edge for this. I doing a subsurf but the edges get ruined as you can see in the second image. What is the solution? I tried using the knife tool but that worsens the situation. It creates too many edges.


Wondered if you have tried the submenu of subsurf and choose Simple Subdiv as an alternative to Catmull Clark.

This may get rid of some of the pinching you have.

I am very new to Blender but I did make this object to try it out.
I created a mesh plane extruded the edges to make up the basic shape.
I then made sure to choose all and apply a subsurf.
making sure again that all was selected I did an extrude to make the mesh 3d.
Again make sure all is selected and then apply a smooth.
After this you can change to the Simple subdiv or keep the cattmul Clark subdivision method.
Hope this may help as I said I have only had Blender for about two weeks to play with.

Looks like you’ve applied some crease to some edges.
To check if this is the case, go into edit-mode.
Select all vertices.
Press N-key.
See if there is below the median x,y,z boxes also a “Median Crease W” box. If there is and the value is non-zero you’ve found the problem. To solve it change the value to zero and you’re done.

If it doesn’t work you could also post the .blend-file so we can have a look at it.

EDIT: I just recreated your file and had a different vertex count than you (130 instead of 150). So you probably have some double vertices.

  • Select all vertices (in editmode)
  • W-key --> option 6 (remove doubles)

Crouch, I checked for creases and it showed zero. I figured out what the problem is. I used the knife tool to give the image sharper edges. Unfortunately, the knife cut create additional edges. While extruding, those edges also get extruded and when subsurfed, it gives the shape shown in the image.

I guess I can deselect those edges while extruding or I’ll have to avoid the knife cut and define the edge but adding more vertices.

Thanks though.

How about Wkey, Remove doubles? You might have overlapping vertices there…
Ooops, reread the entire topic more carefully, and it is already suggested. Might be it, exactly. Check it out again by clicking on a vertex (click, don’t use the Bkey) and moving it around. It might reveal the hidden vertex. They might be separated just enough to be greater than the threshold setting of the remove double function.