Need Help with Texture Paint


I’ve been doing everything i can. This is the Node setup i used from a youtube video titled: “Skin material in Blender 2.8 - part 2” by Lance Phan. I unwrapped the object, Rearranged Materials, even manually clicked each node to see if it would make a difference. I cant seem to be able to paint on my mesh.

Any ideas please?

Also I’m sorry if this is a SOLVED topic already.

1 Like

Which node are you wanting to paint to (image node)? The base color or the detail? The Details image slot is selected, but maybe you are needing to select the Base Color png slot there in the texture slots panel before you see your paint?

1 Like

I guess its the Details node i want to paint onnn?.. it seems like the only one that makes sense to draw on. The details.png was outside of the folder i moved it in and redid the node… still nothing…

Do i need to accept all of my modifiers first or something? is that a thing?

1 Like

In texture paint mode are also slots where you have to select the image you want to paint onto. Maybe also try with shift+ click (Only with node wrangler addon) on one of the image nodes to see only that one and try then to see if its the image or something with your brush.

1 Like

It might be my brush then because I ctrl+alt clicked all three image nodes and still nothing.
When i paint, something definitely happens where i get the option to “Save All Images” again and there is a texture stroke in the “Undo History”

What settings would i tweak on the brush to make my stroke appear?

Also, is unwrapping a NECESSITY for Texture Painting?

1 Like

Yes i think uv unwrap is needed. When you dont changed any settings in the brush than thats not the problem maybe have a look at the strength or post a screenshot…

Don’t unwrap a model that already has UV mapping or you will lose that info. Instead add another up layer and create a new uv map for that, you can reference the new uv in an uv node in the shader tree.

I tried plugging details directly into the Material Output. Something crazy happened.

Next, I tried plugging the RGB directly into the Material Output (Which i guess is the same thing) and the same thing happened.

Then, I deleted the “Details” Node all together and plugged the “Base Layer” Node directly into the Materials and it cleared up but I still wasn’t able to paint.

I’m going to delete all of the nodes and textures, start again and see if i can get it to work.

Okay, i delete all materials.
Even the active materials and made new ones
and a new Unwrap.

still nothing…

could it be that my “Mirror” and “Subdivision” modifiers are still active?

Nope…Idk what to do…

It works fine when i make a new project and try to texture paint… all the settings and the steps i took are the same.

Save as a different file name and start from scratch, main thing is to understand how to paint with the texture slots in a simple node tree before getting all that going on and confusing yourself.

Yep, without a file its a guessing game but it could be the texture paint slots or the material that you assign when you have multiple for the same character. I would say test it in a new file with the default cube or open the file in a new scene without loading the ui.

I’d find a simpler tutorial or, watch it again - -

I still havent been able to figure it out.

I copied the objects into a new scene, that didn’t work.
Ugh this is driving me crazy. I’m so frustrated.
I’m going to just skip the texture process and keep it simpler next time. Build objects as the texture and see if i can get it right next time.