Need help with texture probelms

texturing
(nixodemus1) #1

Hi, im nixodemus1 im making this game called TWTWE in the blender game engine, ive been doing this for a while. A problem popped up a while back that I have been unable to fix. Sometimes certain textures will show up as just black boxes, and i have no clue what causes this. the material and textures are all properly in place, and the characters only SOMETIMES become black boxes but are usually fine. I’m wondering if anybody knows what causes this. for more reference, i made a rant video a while back, sorry to make you guys scroll through a video, but i dont have any pictures on hand.

the video

section about the texture problem starts at 3:30 and last till 7:13

1 Like

(- Click for resources) #2

Did you run out of Vram?
If not update your drivers.

1 Like

(nixodemus1) #3

ill give that a try. but its not like it only happens to me. it seems to happen to everyone who plays. which is why im confused.

0 Likes

(- Click for resources) #4

Maybe the blend is corrupt, append everything in a new blend, see if that works

0 Likes

(nixodemus1) #5

alright ill give that a try after school and let you know how it goes.

1 Like

(nixodemus1) #6

Tried apending, came back linked. Thought “no problem I’ll just make it local” button dont work, option grayed out. Tried the same thing with make single user. It refuses to let me append over my game into a freash file. Still working on it.

0 Likes

(nixodemus1) #7

Alright a friend of mine got back to me and helped me out. he actually had seen the problem before and was able to explain it to me, as well as give me a temporary work around. Thank you for trying to help @Cotaks I really do appreciate it. If any mods are around, you can close this thread now!

0 Likes

(- Click for resources) #8

Np, but what was the solution?

So other people with this problem can fix it as well.

0 Likes

(nixodemus1) #9

Alright, so for people coming along after the fact, the texture problem is caused by blender not really handling lots of textures well. I have not been very good in being smart with my materials, and thus thanks to the large number of high quality images with numerous copies, blender crapped its pants, if you will pardon my french. The best way to fix this? be better with your materials. downscale the resolution of your hd images. delete copies. just trying and be smarter in that regard.

now since thats a lot of work that i WILL eventually get to but not right now, here is the workaround my friend suggested as a temporary solution: just have planes with the materials on them. and hide them in the geometry. ideally, you would want them somewhere within the camera’s view, but you dont have to. This FORCES blender to load the materials which should stop the black boxes for now. Once again, this is a temporary solution. if you really want them to go away, start working on being more economical with your images. Hope this helps whoever needs this information!

0 Likes

(Monster) #10

In the past I had similar problem. The cause was more because of missing materials (meshes without material). But this does not sound like your problem.

0 Likes