Need help with textures not showing in BGE !!!

Hi guys, ive recently started using Blender’s game engine ( and i mean like today)

Ive come across a problem when i start the game, to try and view the Uv maps.

as u can see (pic B) its there when i preview it and when i run (pic A) its gone. Is it flipped?


Is it flipped?
Turn the face round and have a look. Check direction of face normals

Ive clicked the “flip direction” button and that doesnt cut it. is it lighting? maybe im not setting something up properly?

EDIT:

When i use just the normal internal renderer everything is okay and i see the textures.

solved it. It wasnt in GLSL

I have some very odd result with a model of mine when experimenting with the BGE.

Attached to the post a Cube on a Plane, both unwrapped and assigned to a texture (that is packed) , and both using a same material+texture.

In Blender Render engine, there’s no problem, in the 3D View, there’s no problem.

Now in the Blender Game engine, in the 3D View there’s no problem, but now if i press P to activate the game engine :

  • In Single Texture display :
    http://i.imgur.com/RY4az.jpg
    It actually looks like the viewport in Blender Render when it’s set to Multitexture display, though the shadow are less dark

  • In GLSL display :
    http://i.imgur.com/8IWC2.jpg
    It actually looks like the render in Blender Render, logically.

  • In Multitexture display :
    http://i.imgur.com/6pvrE.jpg
    It looks like what would happen if i had the material set to Shadeless.
    But it is not set to Shadeless of course.

And now for even more bizarre , add a Subsurf modifier to that cube, do not apply the modifier and look what happens in Single Texture , GLSL and Multitexture display when pressing P.
When you’ll try Multitexture display, it will make the object simply invisible, until you either apply or remove the subsurf modifier.

Do you have a subsurf modifier on your model ?

It sounds to me like a bug, but i have extremely few experience of the BGE so maybe there’s some setting i didn’t noticed.

Attachments

oddBGEmultitex.blend (106 KB)

This happened once to me too - i gave up. So im not sure how to fix it lol - really odd

Ps i have no subsurfs…