Need help with the collada 1.41 plugin

I just tried to import several .dae files from sever different sources. Every time I get this message in the console.

FEEDBACK: Illusoft Collada 1.4 Plugin v0.3.159 started
Traceback (most recent call last):
File “C:\Program Files\Blender Foundation\Blender249.blender\scripts\bpymodul
es\colladaImEx\cstartup.py”, line 609, in ButtonEvent
transl = translator.Translator(doImport,version,debug,fileName, useTrian
gles, usePolygons, bakeMatrices, exportSelection, newScene, clearScene, lookAt,
usePhysics, exportCurrentScene, exportRelativePaths, useUV, sampleAnimation, onl
yMainScene)
File “C:\Program Files\Blender Foundation\Blender249.blender\scripts\bpymodul
es\colladaImEx ranslator.py”, line 61, in init
self.__Import(fileName)
File “C:\Program Files\Blender Foundation\Blender249.blender\scripts\bpymodul
es\colladaImEx ranslator.py”, line 67, in __Import
documentTranslator.Import(fileName)
File “C:\Program Files\Blender Foundation\Blender249.blender\scripts\bpymodul
es\colladaImEx ranslator.py”, line 247, in Import
self.colladaDocument.LoadDocumentFromFile(fileName)
File “C:\Program Files\Blender Foundation\Blender249.blender\scripts\bpymodul
es\colladaImEx\collada.py”, line 72, in LoadDocumentFromFile
doc = parse( filename )
File “C:\PYTHON26\Lib\xml\dom\minidom.py”, line 1917, in parse
from xml.dom import expatbuilder
File “C:\PYTHON26\Lib\xml\dom\expatbuilder.py”, line 32, in <module>
from xml.parsers import expat
File “C:\PYTHON26\Lib\xml\parsers\expat.py”, line 4, in <module>
from pyexpat import *
ImportError: Module use of python25.dll conflicts with this version of Python.

I am using blender version 2.49 until 2.5 comes out of alpha. I tried several things including downgrading my pythonpath. Nothing seemed to work. Any advise?

Hi SHABA1, it looks like you have to install python 2.5 on your system.
migius

I cannot run blender2.5 right now. I have too many things that will not run in python3.1

ImportError: Module use of python25.dll conflicts with this version of Python.
i meant something wrong with your python installation: are you sure you have both: python-version-2.5 and python-version-2.6

Yes migius I have python 2.5 in C:\Python25. I have the default python path set up to use that since everything ELSE that I use the requires python seems to like it. I also have python2.6 in C:\Python26. I tired setting the system pythonpath env variable to 2.5 first and got that messege. Then I tried setting it (PYTHONPATH) to use the python2.6 lib,dll and lib\site-packages directory and got the same message. So I am mystified.