Need help with the grease pencil stroke color problem

Hi Blender community!

I am new here and I hope to get more involved going forth. Also, I am new to the software excited about the new 2.8 updates and decided to finally learn the amazing tool.

Here is my problem. After I drew using the greasepencil, the color of the stroke is always green. When I change color, it has no effect on my stroke. You can also see the problem in this video capture. Any help in how I can remove this weird green color on my stroke would be greatly appreciated.

Thank you in advance!
:slight_smile:
Hyun

Onion Skinning coloring is tinting in Blue keyframes after current one and in Green before current one.
So, there is a chance that you wrote those lines, changed active frame, made a little dot somewhere without noticing. And now, what is written is considered as a previous keyframe intended to be shown as Green.

You may also forget that you have played with layer tinting in Adjustments sub-panel of Layers panel.

Or it may be result of a forgotten Hue/Saturaton or Tint modifier.

Hi Zeauro, thank you so much for your reply! I am completely new to Blender and I am not following your suggestions. If you can guide me with a description of where in the menu I can adjust would be immensely helpful.

On same editor, that displays material settings, you have to check 2 different tabs.

  • Object Data tab, the one with the green Grease Pencil Stroke icon. Under this one, open Onion Skinning panel and untick checkbox Custom Colors subpanel. If color in viewport is still not correct, open Layers panel and subpanel called Adjustements. If into this subpanel, Color is black and Factor value is set to 0 : these are normal defaults. Check the other tab.
  • Modifiers tab, that is the blue wrench icon. If there is a modifier changing the color, delete it.

Thank you so much for your clear and detailed explanation. I tried as you suggested but that weird green color overlay still persists. I believe it is bug in the software. I am going to try re-install. Thank you so much for your help!!

Same problem here.
I’m trying on macos catalina and ipad pro. I think that green color underline an engine error :expressionless: (like purple in 3D blender design)
I try with AMD Prorender engine too but the stroke is a strange green line with lines inside!
Update: i try on windows bootcamp (same imac), all work. So the problem is the macOS :pensive:

18|690x402

Ok, i have found a solution.
User Preferences -> Viewport . I set Grease Pencil Multisampling value to “No Multisample”.

Only in this way it works in a right way on my mac (iMac 27’ i7 late 2017)

You sir, is my HERO!! This solution works for me. Thank you!!

1 Like