need help!


(gargola) #1

could anybody please go here: http://www.megspace.com/computers/blendergargola/Games.html and download the Ghost n Goblins return game? i need some help with the game.You see? the character is supposed to walk the direction it’s facing when you push the up arrow key,but instead it moves only forward,the same with the down arrow key(backwards).what is wrong?i checked everything on the actuators and it’s set right(like on other games i’m making and they work fine) and the camera doesn’t seem to stay at a correct distance and view as i want.please anybody help me! :slight_smile:


(Doc Holiday) #2

Use Force instead dLoc to move Youre Character Arthur. For Forward (UpKey) give -100 in X and for Backward (DownKey) give +100 in X. That should work.
(little Tip: Don’t make Youre Character so much complex. 9040 Polygons!!! That’s not god for gaming, Boddy! In Blender, Youre whole World-Scene should not have so much Polygons.)

Cu, Doc


(Pooba) #3

First of all, the reason that your guy goes the same direction is that you disabled linear movement, which is the little “L” button next to each of the movement number fields (why’d you do that?). To fix it, just make sure that button is pressed in. Second of all, why do you have armatures up on each separate object?! That’ll just slow your game down, just make an animation using the object, the armatures will slow down the game a ton.

Next, your model is was too big. Don’t ahve it be so big (by big i mean lots of polys) you only want at the very most 1000 polygons per character (and that even is stretching it). 9000 is more than any game otu there!

Hope that helps!
Pooba


(gargola) #4

ok! small characters next time! he he! :slight_smile: but nothing that you said solved my problem :frowning: i tried force instead of dloc,but it didn’t solved the problem,the character keep going only back and forward instead of the direction he is facing!(it’s weird,cause the other games i have are set exactly as this one and they work perfectly!)

Pooba:little “L”??? i don’t see a little “L”.where do i click to enable the little “L” again?i don’t remember disabling anything like that on actuators or anywhere else.but to be sure,i checked all the little cubes on the side of the movement actuators(local transformations),but that didn’t worked either!..this is weird! :frowning:
please help!


(Pooba) #5

Those boxes next to the numbers usually have an L on them. MAKE SURE THEY’RE PUSHED IN! That will solve all your problems. Also, don’t use force for character movement, use dloc or linV. A little bit of messing around always makes it work.


(gargola) #6

is it just me or what? i pressed all the “L” boxes (loca transformation) and it didn’t worked!i’ve made all kind of things with that actuators and nothing! :frowning: i don’t understand why!!! all the other games are set the same way and they work! what could be wrong? :frowning:


(gargola) #7

ok,i fixed it! i used force like Doc Holiday said.i was using it in the wrong way.but there is something i don’t understand,why sometimes we got to use dloc for movement and other times we got to use force?anyway,thanx to you guys for all your help,i appreciate it! :slight_smile:


(gargola) #8

by the way,how do you find out how many polygons a model has?


(Doc Holiday) #9

If Your Screen is complete black and You can’t identify any Lines and Your Computer needs 5 Minutes to calculate a new Pic, Then You have to much Polygons! :smiley: Select Your Object and go to Edit Buttons. Have a look at the Decimator in the middle. :wink:

Cu, Doc


(gargola) #10

thanx doc! :slight_smile: