Need some help with nodes interface (noob thing)

I’ve been learning through internet videos and got stuck at texturing part.

What I need is what is at this image. My default intafece don’t let me have access to Global nodes and it open a wierd intercafe on material editing. Everyone teaches using the right way but I don’t know how enable it.

Calm down, don’t curse me, I am a noob.


You are using Blender Internal renderer, which uses rasterizing instead of raytracing like Cycles renderer has. It is the default render setting.

You need to switch to Cycles (which is way more realistic, believe me).

At the top of Blender’s interface, (at the top menu bar thing above the 3d view) there is a dropdown with 3 options. It would say Blender Internal or something, and just click and select Cycles.

omg you saved my life!
thanks man.