Need to Apply Armature with Shape Keys


I purchased a horse model with rigging. I’ve posed the horse the way I want it, and was ready to apply the armature. The reason for this is that I don’t need to animate the horse, only pose it as a sculpture piece. However, the armature won’t apply with shape keys. I’ve found instructions for accomplishing what I need (kind of complicated), but those instructions are for an earlier version of Blender, and don’t work for the newest version. Can someone provide instructions for applying my armature/shape keys in Blender 2.74? Thanks very much! (as you may have suspected, I’m still somewhat of a newbie, so hopefully the procedure won’t be too advanced.) Thanks


One way of doing it by transferring all the shapekeys to a single shapekey that makes it possible to then delete them before applying armature modifier

Another reason I need to apply rigging is because I’m going to have 8 horses in one scene, and with all that rigging, etc, Blender becomes unwieldy and won’t function. I’m hoping by eliminating all the unnecessary baggage, I can build my scene. Thanks again. p.s. Richard, we must have posted at exactly the same time, coz your post wasn’t there when I posted this. I will try your suggestion, and let you know how I managed. Thanks so much.

Richard, this horse has numerous shape keys. I was able to eliminate most of them except the last four. No matter what I do, deleting them always causes a distortion of the mesh. Could you possibly take a look at the file, and see what would be required to remove ALL shape keys? Thanks very much.[ATTACH]389103[/ATTACH]

Still need help with this if anyone has any ideas. Thanks!

See attached blend file.
See video below. The rigged model is initially duplicated onto a separate layer to check there was no change to the final object when the armature had been removed

You should watch the 1080p version


Horse_SHAPEKEYS.blend (1.58 MB)

Richard, somehow I got your method to work… though I’m not sure was done differently. I was able to remove armature, leaving just final horse. I can move final horse, but when I try to rotate, eyes and jaws are left behind. (see screenshot). I’ve made sure to select all; tried joining and grouping… can’t get anything to work. Can you please advise the best way to combine all horse elements so that I can easily move/rotate, etc several horses into their respective positions? I essentially need to create a non-animated scene with several horses, plus other objects. Thanks again very much!

The eyes and mouth are parented to a bone in the armature. You need to clear this parenting with Alt+A but keeping the transform. I do this for each of these objects in the previous video. Also I recall the mouth also had an armature modifier that also needs to be removed.

The objects can all be joined together at the end with Ctrl+J

Ah, okay, I will keep playing with this. When joining before clearing parents, the hair went completely whacky. Hopefully, will be better luck after clearing. Thanks again.

I had followed your actions in the video re: clearing parents (alt +p) for eyes and jaws before I posted. However, I did it again; repeatedly actually, yet the eyes and jaws simply will not rotate with the rest of the horse. Additionally, I can’t find any armature modifier for the mouth. Finally, when I “join” all, the hair goes completely out of whack. Not sure what to do at this point.

I think there are a number of ways to do this(I haven’t read thoroughly) but I don’t think there is a reason to actually apply the armature modifier. All that does is place the model in the armature pose, which is accomplishable by duplicating the model, using join as shapes, and then replacing the old basis shape with the newly created key(or blending it).

Depending on your circumstances the actual method for doing that may be different than my description, but in general that’s the idea.

This is a tangent, and as I’ve said I haven’t read thoroughly, but regarding the issue you seem to be talking about the end here it sounds like you may be running into a certain bug where the mesh has an invisible “true” shape which is not represented by any of its shape keys(including basis). In order to fix this all you have to do is make a copy of the key you WANT to be the real shape/basis, and then delete the current basis while the copy is directly under it. For whatever reason, it seems to update Blender’s internal mesh data to match whatever shape was directly under teh base shape, although I don’t know the details.

Anyway apologies for not reading thoroughly if this isn’t really useful information to you/addressing your problem.

Still no luck here. Will continue by trial and error. Thnx

Hi Metrov,

I tried to understand what you wanted to do and so I created the attached file.


Horse_SHAPEKEYS_parent.blend (7.73 MB)

Horse_SHAPEKEYS.blend (3.56 MB)

I believe this is what you want, if so, let me know, I’ll give a quick rundown

Hi Mathias,

Thanks very much for your file… we are getting close! Exactly what I need to do is this: I want to create a scene with six horses in six different poses. When I first duplicated the horses in their original state, (i.e. with rigging, etc), Blender became too unweildy… I could barely move things around. So I want to pose the initial horse, then duplicate. After I duplicate initial horse, then I want to apply the rigging and delete the bones. Then I want to pose the 2nd horse, and repeat until I have six horses in different poses.

In your file, it looks like you applied the rigging… that’s fine… but the eyes are still not joined/or parented (whichever is best)… I just want to be able to rotate the horse without leaving the eyes and jaws behind. It looks like the jaws are joined/connected, but not the eyes.

If you have a sec to create a new file the way I need it, I would be very grateful. Thanks again.

Sorry, I didn’t see that the eyes moved!

ok, here is how you do it from your original file.

1- On the armature deformer of the horse, you click on Apply as a shape key,
2- Then in the shapekeys, you delete ALL the shapekeys above the last one created, and at last you delete it, so you don’t have anymore shapekey and the mesh should have stayed in the position you wanted.
3- Apply the armature of the jaw
4- remove the parent of the jaw
5- select the jaw, shift select the horse mesh, Ctrl+P, parent(KeepTransform)
For the eyes,
6- duplicate the eyes
7- delete the parent on the original eye (they should move to another location)
8- add a copyRotation and copyLocation on the original eye, the target is the duplicated eye. (At the end of this step, all the eyes should be at the right place).
9- select the original eye with the constraint, do Ctrl_A apply visual transform, then you can delete the constraint (the eye should stay at the right place) and you can delete the duplicated eye.
10- select the eye, shift select the horse mesh, Ctrl+P, parent(KeepTransform)

that should do it! :slight_smile: