Need to Reduce Render Noise - MIP Atrium [WIP]

For over the last year and some, I’ve been working on / off modeling the Atrium of the Mcmaster Innovation Park building, through photo and in person visits.


*Slightly older render which used denoise

I’m using the Atrium as the main set piece in a short animation I’m closing to complete.

Now, for what this is doing here

I’m in need of reducing the amount of noise, the skylight lit space produces in the render.

With the accuracy of the recreation having been my main focus during the time when I was most interested in this project, I have the enclosed space lite through the skylight in the roof.


I use the world background with a Nishita sky texture node for the light, and the skylight is setup as shown above with the glass shader shown below.

There are also some large hidden lights reflecting off of the walls and a number of small in-ceiling circle lights (so I call them anyways), shown below.



But I don’t necessarily need them turned on in the render.

Rendering for Reference

I’m not sure if this depth is entirely necessary but I’ll show some of the current rendering results I get with the settings shown below. I’ve tested with various sample amounts and played with light bounce amounts, though samples would get into 5000 and still have clear visible noise.

I’ve got three renders here, all have the same render settings with exception to one having denoising turned on and two having different building lights turned on.
I’ll also mark the times as displayed in Blender underneath the rendered image.

Lights off, Denoising


2:16.47

Lights off


2:11.57

Small Lights on


2:25.09

Small and Large Lights on


2:33.37

For my concluding questions.

Should I avoid lighting an enclosed scene the way I currently am?

Should I keep the extra lights in the building, off?

and

Is there a workaround that maintains the affect the glass in the skylight has on the scenes lighting?

I appreciate anyone who has a workaround for the skylight.

I have moved the discussion to a more appropriate category / topic.

You can find it here: Getting lots of noise with my skylight lit scene

I am not sure if this can help, but your glass node set is not right.
It should be like this:


You did not mention any light portal. Did you use them?