Needing Game Engine help

Okay, here’s what I want to do. I have a simple bipedal mech with armatures set up. I did a short 40 frame start-up animation. I was wondering if it’s possible to have the scene start with this animation, stop, and let the player take control. Also, if I can use armature animations for things like walking in the game engine. I hope I don’t have to use IPO, or if there’s a way to convert action to IPO, so long he moves well. Any suggestions?

Here’s how (may not be accurate):

  • Make sure you are in object mode
  • Select your animated object
  • Press F4 to get to the logic bricks
  • Add an Always sensor, AND controller and an ipo actuator (don’t worry, you don’t need to use the ipo editor for this if you already animated it with the timeline)
  • If you want the animation to play once and stop then press the button with the three dots in the Always sensor (disable it). If you want it to repeat let it stay pressed.
  • Change the values in the ipo actuator to play and the start frame and end frame.

Press P and behold! :slight_smile:

Not sure if armatures work to make the object actually move (walk). I think I saw a decent sample somewhere that worked… well… it moved.

I tried it on the armature; do you mean I have to do the animation to the mesh?

No, it should be the armature if you animated that armature that is. If you rigged it correctly then I don’t know what the problem is. I made a quick dummy test by making two armatures parent to a cube and I was able to animate it.

How did you do your animations? I just used the timline and inserted keyframes (I -> LocRot).

Yeah, that’s what I did, but I can’t seem to make it animate in the game mode. For example:
I have the armatures on the guns animated to spin, and I tried applying that animation for whenever the left mouse button is clicked. But, whenever I press P and left click, nothing happens.

Hello and welcome
you must set Logic Bricks for the action ( Armatures use Action keys not IPO ones)
Once done with Action animations you must do:
Mouse Sensor - Left Click -> AND -> Action Actuator - and set Sta and End with the desired Action key frames.
here’s an old and outdated tut maybe helpful:

Oh, I don’t even have an Action actuator I think. I’m using 2.45.

I haven’t had a chance to use it just yet (stuck at school right now) but I think I know what I did wrong. Perhaps I’ll follow through this tutorial and just apply it to my mech instead. Either way, thanks for the help. I’ll post weather or not it works for me.

o course you have it but you must select the armature first then you will see it in his actuator list :smiley:

I feel dumb. My good friend just showed me how stupid I am. Apparently, I had the armature modifier on the mesh, but totally forgot that modifiers don’t apply to the game engine. This is my first time using armatures, so I learned something. I forgot to parent the mesh and the armature, but it’s working now. OTO, I’m still going to go through that tutorial, but just using my mech instead. Thanks for your help, everyone!

Ooooh, right. I haven’t used armatures in the in-game engine yet. Good to know!