Negative pulses play animations?

Linked to my script is an Action actuator set on ‘Play’ for attacking. Upon initialisation the character should stand still, but instead it plays the attack animation once.

After trying to debug why this was happening I found a negative pulse from the python script was activating it. The script line is written as


There is definately nothing else triggering the actuator. There are several conditions for it to be played and none of them are met at startup.

Is this a feature or a bug?

I’ve tried it, with the same Result. I would also say this is a Bug. IPO-Play and Action-Flipper works correct. You should write this into the BugTracker.

And i think i found a second Bug on this Actuator. The Flipper Mode does not work proper:
Use a Keyboard Sensor to pulse the Actuator.
Hit the Key and the Armature is fading to the EndFrame.
Release the Key and the Armature is fading back to the StartFrame.
Hit the Key again, before it arrives the StartFrame, it should fade from the current Frame to the End. But now, it jumps to the StartFrame and starts a new Animation from the Beginning.
This works ok with IPO-Flipper. Cand anybody confirm this?