Neon Effect Blender Doesn’t Work


Hi everyone, so I’m using this video to make a glowing effect in blender 2.8 using Cycles. So I’m working on the glow effect and I’ve follow their steps verbatim and even tried rendering it but nothing seems to work I always get a flat colored non-glowing part.

My Composite

So, the quick answer is to connect the output of your Glare node into the input of your Composite node. Right now, your image goes straight into your Composite node without any effect being applied.

Think of your Composite node as the final node in your node tree. Anything that happens outside a branch that traces from left to right and ends going into the Composite node doesn’t go into your final image.

Here’s a link to the manual that talks about the use of the Composite node:

I’m going to guess you weren’t doing it exactly as he says. and why would you - it’s not the best or correct way.

Fix should be easy. Also connect the output of the glare node to the input of the composite node, and then try again.

EDIT: beaten to it by @Hunkadoodle

@Roken @Hunkadoodle

Like this? I’m not sure really what to do seeing as I’m very, very new to blender.

@Roken has a good point. I answered the question without watching the video. I assumed it was related to Andrew Price’s Neon tutorial (part one here:, but I stand corrected. I really wouldn’t recommend saving your images by saving the Viewer Node output. That is not a good practice. The Viewer Node can be connected to the output of any node in your node tree for visualization, but if it isn’t connected to the final output in your tree, you will not be saving the image with all modifications applied.

Regarding your question about connecting the nodes correctly, yes. You have the Composite Node connected correctly. You now need to make sure compositing is turned on in the Post Processing panel in the Output Settings ( Finally, render with F12 in order for your composite to process all the way through your compositing node tree and output to the Render Result.

You are also rendering with a transparent film background, and so can’t see the glare. Add a background image with Alpha Over and it becomes visible.


Just transparent film:

Background composited:

There was no re-render here. Simply a change in the compositing nodes. Bear in mind you are working on a final image for the glare. With a transparent background, there is nothing to show the glare against.