Never before seen edit-mode problem (weird black stains)

Hello there. Im having two big problems. Working on a very complex model something I’ve never seen before happened, in two elements of the model.
I’ll call these elements A and B (see screenshot or download help.blend).

http://gls.areaunix.org/forum/snapshotA.jpg

http://gls.areaunix.org/forum/snapshotB.jpg

The problem with A is a weird bump in the middle, that i think I can fix scaling along the z axis, but when I press “s” all the vertices collapse in the same area. It’s quite strange. Any ideas?

The problem with B is different: while not in edit-mode everything looks normal, even the render looks fine; in edit-mode with sub-surf on, you can see some black stains. Edit > Normals > Recalculate Outside (or Inside) doesnt solve the problem, infact I dont think it is a Normal issue.

I tried removing doubles and the “clean meshes” script, with no result.

Im using Blender 2.44 (but this happens with 2.33 too) under Ubuntu Linux.

um… is smooth on mabye and how does the render look cuz if the render is fine then u probly have smooth on

I’m not sure about what caused it, but I was able to fix it ^^

I messed around a bith with the scales and stuff

http://pp.kpnet.fi/rahkila/help_2.blend

that’s the fixed .blend file

What did you import these paths from? You’re right, this is very strange. It’s almost like you have a hybrid between a mesh and a path. The normals are all facing towards the vertex points rather than out from the faces and the mesh can not be edited.

Yeah, well over here the normals are all parallel to the faces ??? And you can’t scale or edit any part of the mesh …

The second artifact problem seems to have to do with the subsurf level you selected for some reason you have it set to 3 while you have the render level at 2 … just set the level to 2 and the artifacts will disappear .

In object mode apply scale and rotation [Ctrl+a]. Weirdest thing I’ve ever seen.

I’ve missed to tell you I had imported the path from Inkscape.
Ctrl+A (Apply scale and rotation) solved both problems! Thanks everyone, you rock! :slight_smile: