New Blender Mesh sharing site


(Abavagada) #1

I asked a while ago about whether people would be interested in a site to share basic blender files. Well, I have currently pulled together a site for doing just that.

http://www.abavagada.net/chameleon/

It is set up on a very simple and basic level. A person can view the list of objects they can download, and download the items they want. Simple sort and selection engines also exist, to make the viewing easier.

There is also an uploading section where people can upload their objects along with thumbnail images of the object rendered.

Currently, only files of types .jpg, .jpeg, .gif, .blend, and .zip may be uploaded, and no files over 1 meg can be uploaded. After all, these are supposed to be basic meshes, not major works.

Please test it out and let me know what you think. I have written all the script for the site from scratch, so I can most likely add any extras to the site that seem reasonable.

As for a question… who do I contact to try and get this site posted on a list of Blender resources?


(ectizen) #2

Downloading doesn’t work for me (Mozilla 1.0 on Linux). I don’t know if this is the cause of the problem, but looking at the html, it seems the <a> tag for the download button isn’t closed.


(Abavagada) #3

Thanks for finding that. I have added the </a> tag.
If this still doesn’t work, please tell me exactly what happens when you try to download.


(pofo) #4

When I try downloading I just get back to the gallery.

This is a good initiative, hope it becomes popular.
I’ll submit a model or two if you can get the page to work :slight_smile:

  1. pofo

(Abavagada) #5

Pofo. what browser are you using?


(ectizen) #6

Still doesn’t work for me (still Mozilla 1.0 and Konqueror 2.2.1 on Linux). Does that “onClick” stuff really work? Could that be a browser specific “feature”?


(Abavagada) #7

The onclick stuff works.
The problem was that it was just passing a single “href” to the filename.
This only works for some files, like zip files. It wasn’t working for the .blend file.

So, I made some changes and the method of downloading the file internally is different. Please try now.

Thanks for your patience and help in debugging this.


(ectizen) #8

Ok, .zips work :slight_smile:

.blend doesn’t - the browser doesn’t know what to do with it, so it just displays it.

Maybe only using zips would be better - smaller, faster downloads, and less troublesome to serve.


(Abavagada) #9

Odd indeed. I got the .blend file to download now, with the changes I made.

If this remains a problem, I will make it a requirement to zip all files.


(theeth) #10

zip files are better any, since .blend sometimes give problems when downloading as is (at least for me).

you could setup a batch file to zip the .blend once you recieve them.

good job, I think that’s a very good idea.

Martin
PS: does SysAdm still have his object ressource on his site?


(ectizen) #11

I think the .blends can cause problems if the web server doesn’t know what they are. As far as I can tell, your server is claiming they are “text/plain”, which would be why my browser wants to display them. Are you able to configure your server to set content-type header for specific file types? Setting it to something like application/octet-stream would probably fix the problem.


(Abavagada) #12

Well, since I have coded this whole thing from scratch, I can basically change anything… as long as I know what needs to be done.

When I write out the page, I print “Content-type: text/html”.

So, I can have it print out any other headers instead. I just need to know what works.

Do you have any insite into those settings, or a site that could help me?

Thanks


(Abavagada) #13

ok. Looked it up.
application/octet-stream should work, and I implemented it.
If there is still a problem, I will just have to make all files zip files.


(ectizen) #14

Hmm… you beat me to it.
Well, here’s my post anyway :slight_smile:

Here are a couple of links on the topic of Content-type: headers:

http://ppewww.ph.gla.ac.uk/~flavell/www/content-type.html this one deals with these sorts of issues
http://www.w3.org/Protocols/HTTP/Object_Headers.html
http://www.w3.org/Protocols/rfc1341/4_Content-Type.html

From the looks of these, setting the content type to application/octet-stream (or even something like application/x-blender) in the bit of cgi that returns the .blend will do the trick.

BTW ‘TARGET="_new"’ isn’t helping :slight_smile:


(ectizen) #15

Hmm… still isn’t working… it’s still arriving as “text/plain”

Hang on. Is your cgi redirecting to the URL for .blend? If that’s the case, then setting the content-type in the cgi won’t help - the web server needs to set it, since it’s handling the final request.


(theeth) #16

well, it worked here, at least (using IE 5.5)

Martin


(ectizen) #17

IE is known for ignoring “text/plain” content types, which explains why this would work for you.
Still not working for me.

Hmm… your site is running Apache 1.3.something. Ok, if your cgi is simply redirecting (which I think it is), you can do this:

If you have access to your server’s configuration, you can add one of these lines

AddEncoding octet-stream blend
AddEncoding x-blender blend

to the relevant config file (/etc/httpd/conf/srm.conf on my system). Restarting the server process will probably be required (/etc/rc.d/init.d/httpd restart on my system)

If you don’t have acces to the config file, your web hosting provider may have some kind of web interface to do this for you.


(Abavagada) #18

I added .blend octet-stream to the apache handler.

If this doesn’t work, I really don’t know what else to do.


(pofo) #19

Works for me now :slight_smile:


(ectizen) #20

It’s still “text/plain”

I think the configuration is in the wrong place, which I’m sure wasn’t helped by me providing faulty info :slight_smile:

After a full night’s sleep, and a bunch of testing, I’ve found that this configuration option will work:

AddType application/octet-stream .blend

However this probably isn’t all that helpful, since I’m now fairly certain that you’re using a web host provider, and don’t have access to the raw configuration files.
Is there anything in the server configuration interface for mime types perhaps? Or maybe simply types?

Alternatively, a simple link which we could Right-click/Save As would work, too :wink:
Or even, .zips only.