New Blender User. On my first project. A rainbow birthday Cake

Having a problem with how the SubSurface Modifier is interacting with my mesh. I’m not sure how to solve my problem. The following pictures will show whats happening.

First try to get rid of all that n-gons.
See here for some input.

Btw. prepare yourself for this thread to be moved to a support forum.

I will Chalybeum. I thought n-gons on a flat portion of a mesh were ok though. Thats the only reason I didnt worry about them. I can see them as being the culprit. Just being too wordy, its my nature sorry lol. Thanks for the advice.

"Basically, add geometry." SubSurf needs geometry to do realistic calculations. For instance, fill the surface of the cake with triangles and add more bevel lines. (None of this is “hand work,” just fills and/or subdivides.)

You don’t necessarily need “a lot of” geometry, just more of it than you now have.

You will generically find that “large single polygons” (of any shape) produce less-satisfying results than when those same polygons are subdivided a few times. Most calculations are “per face,” so it pays to have “more faces” especially where detail is important, as with this cake. When you start working on the texture of the layers themselves, for instance, you’ll probably want to subdivide these areas more than you do the iced areas, because that’s what will ultimately “sell the shot.”

You’re not totally wrong. n-gons can be ok on flat surfaces.
But they tend to cause trouble with the shading of their neighbouring faces.

Thanks for all the advice from both of you. Looking back, yes not enough geometry, I see what your saying. I’ll get to work on more topology and get back with results. =D

Heres my progress. Thanks for the advice. I realized part of my problem was I was building both sides of the cake. Using the mirror mod to only model half of the cake removed that ugly seam. I’ve added more topology and it seems to be ok flowwise, although I haven’t tested its flow properly im sure as I’m a very new user.

My next problem is the edge highlighted by the briught green grease pencil mark. It’s way too sharp and I can’t figure out how to soften it properly. I’ve tried dragging the edge to its left towards the center but it doesnt soften the edge as I’d expect. It’s almost as though this edge isnt being affected by the subsurf mod for some reason.

Again thanks for any and all advice, have a great day. =D

I’d turn off subsurf for now. It’s handy sometimes, but sometimes it’s kind of a crutch.

You might wish to consider modeling the cake (frosting) and the layers of the cake as separate objects in a group, since the modifier-stack needed to make the frosting look good probably won’t apply to the cake and vice-versa.

You’ve got two very-different objects here: frosting, and cake.

Here’s my current progress on the cake. I did take your advice concerning splitting the icing and cake into separate objects, thank you very much. I did choose to leave the sub-surf on for the “Icing”. I just had to play with the geometry to get the curve I needed. It seems to work pretty good. The "Icing has a sub-surf+solidify. The “Cake” is just a series of different colored planes with no mods. I think I’m ready to start sculpting/texturing. I’d like some input before I go ahead however. As always thanks for any and all advice, you guys have been immensely helpful thus far. =D