New blender version runs super slow

Hi, so Im having this problem with :
blender 2.74, 2.77 and 2.78 for windows 64 bits. I tried using 32 bits. I updated the drivers of my nvidia GTX 850M to the last version and still not working… and the most strange thing is this problem appears suddenly. I made a lot of renders using 2.70 and 2.77 version and never give me problems… but Now when I run 2.77 takes a lot of time in select basic stuff like "open… " “select…” . I already put this “opengl32.dll” file in the same folder as blender.exe and still going bad.

Do you know why is happening this? I dont have idea. I thought maybe was graphic card but before was not problem with card and is updated…

I run program with nvidia graphics, and as admin but still giving this misterious lag…


Hi, thanks for answer but after reading I think is not same problem. Im not loading any animation in blender, I just open and goes super slow, even with integrated graphics, the another thread is not solved in this point I think…

If you still have the opengl32.dll in the folder, of course it’s going to be slow because Blender won’t use hardware acceleration then. Remove that and try again. Other people have improved performance by switching to integrated graphics, so it’s likely there’s something wrong with nvidia drivers/driver settings/windows that does it.

1 Like

Thank you! I forgot delete when I change into integrated graphics, now looks it works good like always, thanks really :slight_smile:

Good day! I’m having the same problem but I tried looking for the openGL32.dll it’s not there. what should I do?

Blender uses OpenGL for drawing the user interface. OpenGL libraries usually come with the graphics drivers and is hardware accelerated by the GPU.

The openGL32.dll I was talking about is a library for troubleshooting graphics issues. Placing that in the Blender folder disables hardware acceleration so it’s not dependent on the GPU drivers, which can tell a lot if it runs and/or doesn’t have same glitches as with hardware acceleration. It’s too slow for actual use though.

If you’re using nvidia gpu, enough people have had the same problem and the same fix that there must be something wrong with the gpu drivers or Windows. Maybe trying older version of the driver could work but that I don’t know.

how do you change it to integrated graphics?

Hi, on Windows Laptop you can change GPU in desktop shortcut context menu (right mouse) or in driver settings per application.

Cheers, mib

help pls, i am using the Intel graphic thingy and Blender won’t run without the opengl32.dll, when i remove the opengl32.dll and reopen blender it says “a graphics card with support for OpenGL 3.3 or higher is required. Installing the lastest driver for your graphics card may resolve the issue. the programmwill now close.” and then if i put the opengl32.dll in, it works normally, it’s just running like it’s on 1 - 5 FPS or something.

What video hardware do you have in your system (which Intel Graphics Thingy)? What version of Blender are you trying to run?

Blender is not finding a supported video card with the required OpenGL version. Putting the opengl32.dll file in place provides a working OpenGL but one implemented in software with no hardware acceleration, so as you see it’s not terribly useful unless you’re desperate.

i don’t know, it’s just, if i don’t have the opengl32.dll then it won’t work and will gave off an error and close off

It sounds like your machine is just too old to be supported by the version of Blender that you’re using. If it’s a desktop system you could probably add a graphics card to it.

You may want to try the old Blender 2.79b which is quite a bit different than modern 2.8x+ but it might work on your old hardware:

2.79 —

i am pretty sure that’s the problem because it’s 11 years old