New bug in Blender 2.69 or a messed up setting?

It seems that my Function keys in Blender no longer map as function keys.

For example, F11 now shows as CTRL S to Blender (causing Blender to try to save).

Under Keyboard settings in preferences, I still have, for example, F12 set to Render, but pressing F12 is the same as pressing CTRL P.

Clicking the option under preferences to change Render hot button, then pressing F12 causes CTRL P to appear in the setting.

I can’t figure out what’s happened. Has something happened with my Windows 7 settings?

Any ideas welcomed.


Answering my own post … Apparently there is a button called ‘F lock’ !!! That’s fixed it, lol.