New edges disappear after switching to object mode.


I create a few edges on a box using loop cut and slide. But when I switch back to object mode I can see them in wireframe mode. I appreciate your help.

You’ll need to enable the ‘Draw All Edges’ option in the object display properties

Great. Thank you :slight_smile: