New GPU. Default Blender = fast benchmarks renders. Old confings = slow bench renders

I built myself a new machine with a new GPU. I tried GPU-rendering a couple benchmark files, using an untouched version of Blender. They rendered nice and fast.

But when I customize Blender by bringing in my old startup.blend and userpref.blend, then try the benchmark files again, GPU rendering is about half as fast as it should be. I checked prefs (looks good: Cycles is set to use CUDA, and my new GPU), and the Rendering tab in Properties is set to GPU Compute (although weirdly enough it’s grayed out, at least in startup.blend).

Loading factory settings and re-naming my custom startup.blend and userpref.blend files so they’re ignored at launch doesn’t seem to fix the problem. Once this particular setup of Blender has been tainted with my past settings, it stays tainted.

What gives? It’s not hard for me to re-setup stuff the way I like it, but this screws up the portability of Blender, and makes reinstalls harder in the future. And in general I’m curious about what the problem is. Anyone ever run into this?

make sure your GPU is DARK GRAY in the user prefs. light gray means disabled.

Well, there are two things I can think might influence to obtain differences according to old configuration or default settings is used. One is to verify that you have correctly configured Cycles Compute Device as Daedalus_MDW has mentioned. The other is Auto Tile Size addon, so make sure you are using same tiles size always in your tests. Of course, you also always use the same version of Blender in the comparison.
Otherwise, I do not know, maybe some problematic enabled addon.

That has not been clear to me. It should not be greyed out there if you have correctly enabled the GPU from User Preferences. What version of Blender do you use? Does the same thing happen with 2.79 official release?

that’s just your old startup file since you haven’t had GPU yet

to solve
open Blender (new file), set it the way you like & Save as Startup File (ctrl+u)

Thanks for the replies. I managed to figure out the problem by using a fresh portable install and testing my old config files.

If an old userpref.blend is set to use CUDA for Cycles, but Blender detects that the current GPU in your machine is different from the GPU you were using when you last saved userpref.blend, CUDA will effectively be turned off, even if userpref.blend says it should be on. To make Blender “see” the new GPU but keep all of your other old settings, import your old userpref.blend, open Blender, go to Preferences, and go to the System tab. That’s it. Just the act of going to the System tab makes Blender refresh the GPU it’s using. After that, hit “Save User Settings” to make Blender save this new GPU to userpref.blend.

When I was troubleshooting earlier, I must have just been opening Blender with the old config, trying benchmarks, seeing they were slow, going to prefs, seeing CUDA was enabled, going “WTF?”, then restarting Blender without hitting “Save User Settings” (because in my mind, I hadn’t changed anything), trying benchmarks again, seeing they were slow, going “WTF?” Over and over.

It’s not a huge deal once you figure it out, but maybe this is something that could be fixed in a newer version of Blender: if CUDA is turned on in userpref.blend, force Blender to look for GPUs on program launch and use them. If the user wants to toggle on/off individual GPUs later in the System tab, let them do that, but don’t make it so a visit to the System tab is required to refresh the GPU list. It’s confusing to the user, because there’s zero feedback that anything has been changed just by the act of visiting the System tab.