New hardware, Blender now crashes OS

I recently installed an MSI X470 Gaming Pro motherboard, a AMD Ryzen 5 2600 six core processor and 16GB of DDR4 RAM. I am still using my old Graphics card a NVIDIA GTX 970.

Since the upgrade when trying to render volumetrics, smoke and particle sims Blender crashes without warning and also crashes my operating system. The screen goes black, the PC shuts down then reboots.

This problem did not exist before the upgrade to the hardware and none of the other programmes on my PC cause the OS to crash.

My OS is Linux Mint 19.2 and I am using Blender 2.8. I have tried downloading and reinstalling Blender but this did not help, in fact the executable icon in the Blender folder vanished from the folder after the first crash on the newly downloaded Blender. I kept the copy of Blender 2.8 I originally had and the icon for the exe does not vanish on this one.

I have also tried the flatpack version, but this is no better.
I get crashes on GPU and CPU.

If anyone has any idea as to what the problem could be then the info will be much appreciated.