New Inset Polygon Addon

add-ons

(RickyBlender) #41

did a test with latest version

but still the amount value is very sensitive like works only from 0.01 to 0.03
with height around 2.5 to get quad then you get tri’s

i mean is there a way to reduce the sensitivity ?

or may as you said have a proportionel mode

thanks


(howardt) #42

I will consider adding a percentage option for the inset amount for my next update.


(AnandhaRaja) #43

Can i have permission to create installer for this add-on.


(howardt) #44

Are you asking me? Fine by me, if so. Or are you asking for permission to submit to contrib … if so, I don’t have power to grant that.

I hope eventually, if I fix everything, this or something like it could be made part of the distributed Blender, and the need for an installer would go away.


(AnandhaRaja) #45

Are you asking me? Fine by me, if so

yes i asking you
ya sure, i expect this add on distributed with blender after bug fix. mean while i collect the most wanted addon and create installer with install and uninstall support, to avoid copy and paste the files.


(AnandhaRaja) #46

installer for this Inset polygon add-on Download link: here

[note: this installer tested in Windows 7, may be work in vista. iam not sure about xp]


(Meta-Androcto) #47

hi, script is now in release addons.
congrats to howardt. :slight_smile:


(bat3a) #48

hi, script is now in release addons.

there is still a duplicate in the external addons could you delete that :slight_smile:


(Meta-Androcto) #49

bat3a,
no there’s not. external addons or if your looking at upload addons from bf-extensions,
contain a different inset_extrude script.


(bat3a) #50

no there’s not. external addons
OK now there is not, but i swear i saw it man, anyway sorry for bothering you :slight_smile:


(howardt) #51

I just committed a new version of this (0.3) which offers a percent option for specifying the amounts, and also preserves the smoothing and material. You can get it here


(AnandhaRaja) #52

“Inset button” missing in tool shelf (V0.3), you created any hot-key instead of tool shelf button?

Edit:
i disabled the add-on, and i try to enable the add-on but the check box not working.


(howardt) #53

No, I didn’t remove the Inset button. If it is not showing up then either the script failed to compile or it isn’t registered as enabled in User Preferences. To make it easier to install, try using the attached mesh_inset_03.zip.blend instead of that other link. If it still doesn’t work, start blender from the command line and see if it prints any error messages related to mesh_inset.


(MmAaXx) #54

thankyou man!

the ‘mesh_inset_03’ doesnt work with 36733 :S


(AnandhaRaja) #55

Thanks Howardt, now working


(howardt) #56

MmAaXx: I just tried mesh_inset_03 with 36733 and it worked for me. How didn’t it work? Did the “Inset” button not show up? If you start blender from a terminal window, does anything looking like a python error get printed out?


(MmAaXx) #57

Sorry, now works for me too… dont know why :smiley:


(Carrozza) #58

I just downloaded a daily Graphicall build and this add-on is included, BUT the standard “i” keyboard shortcut doesn’t work anymore.
How can we run it interactively, now?


(howardt) #59

This is not the interactive plugin by JoS, sorry. This is a different one, and I didn’t make it interactive.


(Carrozza) #60

Nevermind, sorry, they have a similar name. :o