New install - no rotation holding both buttons (imitate 3 button)

I have just installed a new version of Linux and have installed Blender versions 2.44, 2.5 and 2.65.
It used to be that when I held both mouse buttons down I could rotate the object(s) around. This
is no longer the case. ‘Middle Mouse Button’ is set to ‘rotate’. Emulate 3 Button Mouse is on.
This is true of all 3 Blender versions. Any suggestions ?


Try Alt+LMB

Alt + LMB just allows me to drag the window around on my screen.

Your window manager is taking over that hotkey sequence. Which window manager/desktop environment are you using?

KDE 4.somethin’

Yup… KDE is commandeering your Alt key. In KDE’s control panel, go to System Ssettings -> Window Behavior -> Window Actions and set the Modifier Key to Meta. This makes KDE use your keyboard’s Window key (assuming you have one) instead of Alt.

Hey again. I did as suggested. Double button click now selects object and allows me to the move it around.
Not quite the same thing. Also tried Alt LMB again and nothing.

Are you using left mouse select or right? It sounds a lot like you have left mouse select enabled… and what you think is a double-click to select/move is actual a click/drag to tweak mode.

Also, make sure you have Emulate 3 Button Mouse enabled in User Preferences (it’s under the Input section). Also note that if you have left mouse select enabled, then Emulate 3 Button Mouse might not work as expected (it grays out when left mouse select is activated).

I use ‘right button select’ and ‘emulate 3 button’ on.

Ouch…! I never had use for my mouse wheel so I would never suspect it relevant. But it was (is). For some reason I
squished it and sure enough the cube rotated in place for me. I was ecstatic…

Thank you Fweeb for you patience and effort(s). At the very least you got me ‘trying’ to do my part. As it is I have a
lot of work ahead of me. I was learning and just getting comfortable with Blender 2.44 runnin’ on Slackware 12. I’ve
upgraded to Slackware 14 and now have Blender 2.44, .50 and .65. I’ve decided to try 2.65 in earnest. “It’s a long way
to Kansas Toto”.

And now I’m off to see the Wizard ( 2.65 ).

Thanks again,

= Paul =

Ah! I’m glad this got solved. It was seriously starting to concern me. I’d assumed that you knew the scroll wheel is the middle mouse button and either you had a mouse without that, or you simply preferred the Alt+click behavior.

In any case, I’m glad it’s gotten sorted out. Have fun with Blender!