New Multi-Gizmo/Select behavior Tip and Question

A recent version of 2.8 did away with the Multi-Gizmo button:

Screenshot_43

I particularly liked it as it I could easily configure it NOT to show the rotate grab rings, which always got in the way and were accidentally pressed.

Now, this button is gone and there are only the 3. What happened to the multi-gizmo?

Screenshot_44

Turns out it can now be added the Default Select button. To do this, I’ve decided to add those same Scale and Move gizmo to my Default Select, which actually makes for a nice sensible UI. Here’s how that’s done:

Now, when I select an object, that gizmo automatically pops up.

Screenshot_46

To hide the gizmo, just press ‘G’, ‘R’, or ‘S’ and proceed.
The only issue is the gizmo can get in the way of selecting. Too bad there’s not a shortcut key to toggle it off/on. Before you just tapped the Select button.

Now you can tap the Cursor button and it will hide the gizmo during selection. That’s the best I got.

Screenshot_47

Any other thoughts on how to hide it during selection?

1 Like

Try “ctrl + ~”(tilde) hotkey if that’s what you need. This hotkey toggles “active object” checkbox.


And now they moved tool options from top bar to “N” panel.
tools
It’s weird how they implemented it, i thought people were asking to add “drag box selecton” option to gizmos but they did it backwards. Instead they added gizmos like a “layer” on top of the current active tool. Why do we need move/rot/scale as active tools then? When now we have the option to combine them like we want without using separate active tools (and drag to box select still doesn’t work in separate active tools, which was the main complaint to begin with). I don’t get it.

2 Likes

Same, it seems redundant to me. I’m glad we can display transform gizmos at all times now, seems practical. It’s a bit like 2.79 when you think of it, except there were no other tools on top of it.

The biggest issue for me is that, like Chipp said, the gizmo gets in the way of selection. Very, very, very annoying, especially when trying to select bones for posing/animating. For that reason, I hide it most of the time. 2.79 didn’t have this issue, so I assume it can be fixed.

1 Like

Yep, same thing for me, it’s a constant annoyance in 2.79 so I tend to keep it hidden and rely on constraining things using keyboard shortcuts. If there was some sort of key that could enable you to select “under” the gizmo graphic, it would probably be used more. I tend to reserve it for specific rotational actions.

I think they did it this way so that new users would be able to figure out how to do these things more easily.

Also I know this isn’t an acceptable solution for a lot of people, but you can still use right-click select mode in 2.8. You don’t have this type of issue while using that selection mode (there isn’t a quick way to place the 3d cursor somewhere without changing the current active tool though).

Edit: Since this is just an issue when modeling, they could probably afford to make holding alt while left clicking in edit mode ignore the gizmo when left-click select is the selection mode (Doing this while in object mode allows you to select objects that are behind other objects).

After using it a bit, I think it works. The Ctrl+~ is the trick to be able to toggle it ON/OFF-- which works great.