New problem with armatures...

I have completed my animation of the walk cycle, and it looks nice (in my opinion) except for ONE thing.
There is ONE leg bone that refuses to animate. It deforms the mesh properly, and the bone attached to it does as well, except this certain bone will not animate at all. I insert keyframes for it and move it in pose mode, and in the Action Editor the keyframes appear normally.
However, when I play the animation that should happen, it just sits there. I have tried deleting the bone and replacing it with new vertex groups, but nothing makes a difference. This is the only bone out of all of them to act like this and I’m completely bewildered.
If this is not enough I will post a blend file.

In unusual cases like these, you should consider making the .blend available for download. That way we can play around with the file and hopefully discover the problem. :slight_smile:

It’s all right, the problem seems to have mysteriously solved itself. Don’t know what I did but I’m not complaining.
edit: this post applies to the old problem