new scripter wants to make 2.5 scripts

Hello people , i need help please , i’m 3DGURU’s collegue in the university “farah” , studying I.T. , i have a question

what version of python must be learned 3 or 2 for making scripts in Blender 2.5 ?

didn’t touch on python yet , just know PHP and C++ .

what is the best source to learn making python scripts for blender’s 2.5 interface ?

i hope that i will enjoy the stay with you :slight_smile:

Trythis thread

and blender 2.5 uses python 3

(and don’t forget there’s a link to the (scant) python api docs from blender 2.5’s help menu.)